Examples: Monday, today, last week, Mar 26, 3/26/04

PREDATOR SENSE NOT WORKING!!!

AtishyaGupta2211AtishyaGupta2211 Posts: 14Member New User
edited February 2018 in Predator Laptops
Hi , In my acer predator helios 300 G3 572-73PE , Predator sense is not working since today morning , Please help as i am not able to control fan speed and overclocking now :anguished:
It was working good till today morning but not working now . Please help

FAQ & Answers

  • SharanjiSharanji Posts: 3,905ACE Pathfinder
    Hi AtishyaGupta2211

    Please check if there was any windows update that was automatically installed on your device.
    Try  a power reset as mentioned in the previous post.
    Also, try a system restore to previous restore point and check if the issue is resolved.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!
  • KishteriousKishterious Posts: 2Member New User
    edited February 2018
    It's the same problem for me as well...None of the above worked. Tried reinstalling the program, but it still didn't work. It's running in the task manager though
  • RanY2JRanY2J Posts: 597Ally
    It's the same problem for me as well...None of the above worked. Tried reinstalling the program, but it still didn't work. It's running in the task manager though
    Quoting @Saphire282

    "Had this issue also, but I think I found a good solution. I recently reinstalled predator, which, I don't know makes a difference because it still wouldn't boot up, I'm mainly just adding it to inform all the steps I took. Once that didn't work, I brought the icon back to my desktop and, figuring it's a windows update issue, I right clicked the icon and went down the menu to "Troubleshoot compatibility" . From there it offered me to run the program in "recommended settings" or else further troubleshoot the program. I clicked recommended settings, it had me test the program using windows 8 settings, and viola! It booted up. After that all I had to do was press next, save those settings for the program, and I've been able to close out and boot it up just fine a few times now. "

    Try this?
    BElieve in YOUrself.
  • KishteriousKishterious Posts: 2Member New User
    RanY2J said:
    It's the same problem for me as well...None of the above worked. Tried reinstalling the program, but it still didn't work. It's running in the task manager though
    Quoting @Saphire282

    "Had this issue also, but I think I found a good solution. I recently reinstalled predator, which, I don't know makes a difference because it still wouldn't boot up, I'm mainly just adding it to inform all the steps I took. Once that didn't work, I brought the icon back to my desktop and, figuring it's a windows update issue, I right clicked the icon and went down the menu to "Troubleshoot compatibility" . From there it offered me to run the program in "recommended settings" or else further troubleshoot the program. I clicked recommended settings, it had me test the program using windows 8 settings, and viola! It booted up. After that all I had to do was press next, save those settings for the program, and I've been able to close out and boot it up just fine a few times now. "

    Try this?
    Nope. Still not working, the logo came up and then it just disappeared, same issue as before. Running in the background.
  • stamatovskistamatovski Posts: 5Member

    Tinkerer

    i have the same problem tried reinstalling, tried system restore i tried the troubleshooting thing and none of it works. my laptop is stuck at stock fan speed and it getting really hot while i game because i cant control the fan speed to cool my notebook down. :((
  • BalatekieBalatekie Posts: 580ACE Pioneer
    Hi! You can right click the Predator Sense icon in desktop and select option "Run as Administrator". 

    Please hit like, if this resolved the issue. 
     :) If you think I've answered your question, please hit the Accept Answer:)

  • badmechincbadmechinc Posts: 1Member New User
    I worked on this, and found that "something" isn't running.  So, I went to the C:\Program Files(x86)\Acer\PredatorSenseService directory.  I then double clicked on every program that started with "PS" (PSAdminAgent, PSAgent, PSCreateDefaultProfile, PSLauncher, PSSvc, PSToastCreator.  Figuring one of these things might not be running. Well, after I did this, I clicked on the Predator Sense App, and it came up fine. I'll have to try this again one-at-a time to see if maybe it's just one single thing that wasn't running(most likely looking was PSAgent, PSAdminAgent, PSSvc). Maybe from there, I can figure out how to fix it to where it will keep running after a reboot.
  • Try following this video to change the registry Predator Sense reads to see if it fixes.


    - Hotel Hero
  • KameKame Posts: 1Member New User
    I worked on this, and found that "something" isn't running.  So, I went to the C:\Program Files(x86)\Acer\PredatorSenseService directory.  I then double clicked on every program that started with "PS" (PSAdminAgent, PSAgent, PSCreateDefaultProfile, PSLauncher, PSSvc, PSToastCreator.  Figuring one of these things might not be running. Well, after I did this, I clicked on the Predator Sense App, and it came up fine. I'll have to try this again one-at-a time to see if maybe it's just one single thing that wasn't running(most likely looking was PSAgent, PSAdminAgent, PSSvc). Maybe from there, I can figure out how to fix it to where it will keep running after a reboot.
    This works for me! thanks
  • UniverseGOD2525UniverseGOD2525 Posts: 10Member New User
    edited January 19
    Kame said:
    I worked on this, and found that "something" isn't running.  So, I went to the C:\Program Files(x86)\Acer\PredatorSenseService directory.  I then double clicked on every program that started with "PS" (PSAdminAgent, PSAgent, PSCreateDefaultProfile, PSLauncher, PSSvc, PSToastCreator.  Figuring one of these things might not be running. Well, after I did this, I clicked on the Predator Sense App, and it came up fine. I'll have to try this again one-at-a time to see if maybe it's just one single thing that wasn't running(most likely looking was PSAgent, PSAdminAgent, PSSvc). Maybe from there, I can figure out how to fix it to where it will keep running after a reboot.
    Tried this but still not working. 
Sign In or Register to comment.

Who's Online154

Ala_bek
Ala_bek
Allen26
Allen26
itace
itace
Laureat
Laureat
Pericotrino
Pericotrino
swenak
swenak
ven98
ven98
Zender
Zender
+146 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.