Examples: Monday, today, last week, Mar 26, 3/26/04

Predator 15 framerate issues

ImranAswadImranAswad Posts: 4Member New User
edited January 14 in Predator Laptops
Hello so this week ive encountered a framerate problem with my Predator 15 laptop 

At first it ran DOOM with 60 fps then it slowly drops to 0. This all started this week where I started to use Adobe After Effects for one of my projects and Im starting to think its the cause of this.
Im very new to all of this and i just need to know how to stop it so please help me out. :anguished:

Best Answer

  • SkelomorphSkelomorph Posts: 256Member Practitioner
    Accepted Answer
    Did you go to the sticky thread and look under FPS drops and try out any of those solutions? Here is it copied from the post.

    These are solutions you can do to either: stop FPS drops, or improve FPS/Performance. Do one step and test until your FPS drops stop. 
    Post below which step fixed the FPS drops.
    1. Go to Settings > Gaming, and disable Game bar, Game DVR, and Game Mode.
    2. Update NVIDIA Drivers from nvidia.com, and Uninstall GeForce Experience.
    3. Update your BIOS to the latest version.
    4. Update the Intel Graphics adapters to latest by: right-clicking the start menu, opening Device Menu, expand Display Drivers, and right-click the Intel(R) HD and update drivers.
    5. Uninstall any 3rd-party screen recording/overlay software.
    6. Uninstall any 3rd-party anti-virus software (e.g. Norton, McAfee, etc.) or cleaning/monitoring software (e.g. CCleaner, Glary Utilities, etc.)
    *Note*
    Refer to the GPU Settings post for graphics settings options.

    Skelo
    If I helped, please click "Like"

    If I answered your question, please mark my post "Yes" to make it easier for others to find the answer!

    "Don't cry because its over, smile because it happened."
    - Dr. Seuss

Answers

  • SkelomorphSkelomorph Posts: 256Member Practitioner
    Try looking here first, and see if any of these will help: https://community.acer.com/en/discussion/537057/community.acer.com/en/discussion/535036/frequent-questions-and-answers-information-guide-update-it-on-1-10-2018

    Also, is Adobe After Effects running in the background? Try closing it.

    Skelo
    If I helped, please click "Like"

    If I answered your question, please mark my post "Yes" to make it easier for others to find the answer!

    "Don't cry because its over, smile because it happened."
    - Dr. Seuss
  • ImranAswadImranAswad Posts: 4Member New User
    @Skelomorph thanks for answering
    Adobe after effects was already closed at the time i was playing games. I even restarted my laptop to check if it would fix the framerate of the videogames but it didnt tho. Yet when i launch after effects it runs normally. The extreme framerate drop happens only when i play games.
    Also the link only lead to my own discussion.
  • ImranAswadImranAswad Posts: 4Member New User
    update:
    ive deleted adobe after effects and restarted my laptop. The framerate still drops so i guess its not after effects
  • SkelomorphSkelomorph Posts: 256Member Practitioner
    Accepted Answer
    Did you go to the sticky thread and look under FPS drops and try out any of those solutions? Here is it copied from the post.

    These are solutions you can do to either: stop FPS drops, or improve FPS/Performance. Do one step and test until your FPS drops stop. 
    Post below which step fixed the FPS drops.
    1. Go to Settings > Gaming, and disable Game bar, Game DVR, and Game Mode.
    2. Update NVIDIA Drivers from nvidia.com, and Uninstall GeForce Experience.
    3. Update your BIOS to the latest version.
    4. Update the Intel Graphics adapters to latest by: right-clicking the start menu, opening Device Menu, expand Display Drivers, and right-click the Intel(R) HD and update drivers.
    5. Uninstall any 3rd-party screen recording/overlay software.
    6. Uninstall any 3rd-party anti-virus software (e.g. Norton, McAfee, etc.) or cleaning/monitoring software (e.g. CCleaner, Glary Utilities, etc.)
    *Note*
    Refer to the GPU Settings post for graphics settings options.

    Skelo
    If I helped, please click "Like"

    If I answered your question, please mark my post "Yes" to make it easier for others to find the answer!

    "Don't cry because its over, smile because it happened."
    - Dr. Seuss
  • ImranAswadImranAswad Posts: 4Member New User
    @Skelomorph
    Disabling the game bar worked hahahah. Didnt realize i turned it on. Thanks you so much  :3 :3 :3 
Sign In or Register to comment.

Who's Online239

Acer-JoeRoot
Acer-JoeRoot
Acer-Manny
Acer-Manny
Arabian
Arabian
Axeloto
Axeloto
dayon
dayon
elevado_85
elevado_85
gr_reaper_20
gr_reaper_20
IronFly
IronFly
JackE
JackE
Katrin
Katrin
kurtkabufke
kurtkabufke
mabaitnatao
mabaitnatao
Merlaak
Merlaak
mh90
mh90
muttdoggy
muttdoggy
padgett
padgett
POTTIVENU
POTTIVENU
TCP
TCP
+221 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Visit our new Windows Mixed Reality forum located in our Gaming segment. The Acer Mixed Reality Headset gives you the freedom to escape the confines of a single room and make the whole world your playground.

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.