Examples: Monday, today, last week, Mar 26, 3/26/04

FPS Drops on the HELIOS 300

Avel18Avel18 Posts: 4Member New User
edited January 13 in Predator Laptops
I bought the laptop around 2 weeks ago, and it was perfectly fine. It still is, however, during sessions where I play one game for more than an hour, fps significantly drops. E.G. Overwatch 120 FPS to 30 - 60 FPS, and Fortnite from 50 - 80 fps to 30 - 50. My temperatures aren't the issue as they stay between 70 and 80 degrees when gaming and my laptop doesn't thermal throttle at all. 
SPECS:
i7 7700HQ @ 2.80 GHz
16 GB RAM
GTX 1060 6GB

FAQ & Answers

  • Try disabling Windows Game mode by going to

    Start Menu > Settings Gear > Gaming > Game Mode

    You may need to be inside the game to disable it.

    Skelo
    Please quote me so I get a notification of your reply!
    If I helped you, like my post and/or select my post as 'Solved'.
    Please put your laptop model in your signature so we can know what device you have.

    Product: Acer Predator Helios 300
    Model: G3-571
    "Don't cry because its over, smile because it happened."
    - Dr. Seuss
  • Avel18Avel18 Posts: 4Member New User
    It says that it supports game mode but it doesn't actually have the option to disable it. Only Game Bar, which is a separate section.
  • vedhsutharvedhsuthar Posts: 27Member Troubleshooter
    How did you installed fortnite? It gives error for me ! Just bought 2 weeks ago, nothing tweaked
  • ven98ven98 Posts: 2,488ACE Pathfinder
    Disable game bar. Make sure your Nvidia and intel drivers are up to date. I suggest you to install the latest Nvidia driver from Nvidia's driver page.
    If your question is about a device you own or want information on, always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    I am not an Acer employee!
  • Avel18Avel18 Posts: 4Member New User
    ven98 said:
    Disable game bar. Make sure your Nvidia and intel drivers are up to date. I suggest you to install the latest Nvidia driver from Nvidia's driver page.
    It helped reduce it, but it doesn't actually stop it from happening. Its alright now though.
  • Avel18Avel18 Posts: 4Member New User
    How did you installed fortnite? It gives error for me ! Just bought 2 weeks ago, nothing tweaked
    I just went on to their website and installed the launcher.
    When it's done downloading, just make an account and then install Fortnite. I can't link it since it doesn't allow me to but just search up "Epic Games Launcher" and it'll come up to download.
Sign In or Register to comment.

Who's Online232

athhar_
athhar_
bobf53
bobf53
brummyfan2
brummyfan2
egydiocoelho
egydiocoelho
GabrieleSena
GabrieleSena
GamingCinemaInc
GamingCinemaInc
Hannes22
Hannes22
IVAN_PC
IVAN_PC
Kamalika
Kamalika
Kno63
Kno63
krokodil194
krokodil194
Mjtzr_7581
Mjtzr_7581
OliverM3
OliverM3
PredatorHelios500
PredatorHelios500
rodolfosorocaba
rodolfosorocaba
sed07
sed07
shah786
shah786
SirSooWotan
SirSooWotan
Stefandb
Stefandb
tpabojita
tpabojita
ven98
ven98
wis
wis
+210 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.