Examples: Monday, today, last week, Mar 26, 3/26/04

Old Acer Aspire 8935G killing me on a singke driver

AllonewordAlloneword Posts: 4Member New User
edited October 2017 in Legacy Laptops and Netbooks
Fresh install of Win 10 Pro and everything is set up fine except for a sinlge driver for it' IR port that i cannot get working no matter what i have tried, tried right clicking it and updating the driver that way and nothing work always code 31 then do complete install using the software in compatablilty mode no matter what settings i try, any suggestions ?

All1

Best Answer

FAQ & Answers

  • AllonewordAlloneword Posts: 4Member New User
    Sorry about missing this out "from Device Manager"

    PCI\VEN_1217&DEV_8130&SUBSYS_019F1025&REV_01
    PCI\VEN_1217&DEV_8130&SUBSYS_019F1025
    PCI\VEN_1217&DEV_8130&CC_018000
    PCI\VEN_1217&DEV_8130&CC_0180

    All1
  • IronFlyIronFly Posts: 18,415ACE Trailblazer
    that hardware IDs is from the O2Micro Integrated MS/MSPRO/xD Controller Driver, not an iR controller.

    I'm not an Acer employee.
  • AllonewordAlloneword Posts: 4Member New User
    I have spent so much time on this my brain is screwed up, indeed your right the ID string should be
    ACPI\VEN_WEC&DEV_1020
    ACPI\WEC1020
    *WEC1020

    I'm so sorry about that IronFly

    All1
  • IronFlyIronFly Posts: 18,415ACE Trailblazer
    Accepted Answer
    i found this:

    Solution for the hardware error: ACPI\VEN_WEC&DEV_1020

    also called: Nuvoton CIR driver

    Search for the next driver:

    nuvotron_cir_8.1.64.5000

    (Yes!, NuvotRRRRRRon) with R, its not a mistake! so i think without R could be fine anyway.

    and then, Go to the device Manager panel, right click over the hardware error, upgrade device software, search for local device software (in the computer), select from list, use disc, go to the driver location and open  any file called nuvotonhidcir.cir,  select:
    Nuvoton HID CIR Receiver, INSTALL.

    and thats all!, no more warnings on device manager.

    It Works for me on Windows 10.

    https://answers.microsoft.com/it-it/windows/forum/windows_8-hardware/driver-nuvoton-cir-tranceiver/07df7feb-1415-4c9c-ba84-86eb8632742e?auth=1

    check if any of the available version here is good:

    http://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=select&id=137&lang=en

    website is 100% trustable



    I'm not an Acer employee.
  • AllonewordAlloneword Posts: 4Member New User
    Well using those links was fine to a point, I could not find this "nuvotron_cir_8.1.64.5000" driver anywhere apart from some very iffy sites, however i did manage to find a 15GB set of files (I know 15GB on usenet) called "MCS - MCS_Drivers_Disk_10.4.54" and in there was the file in question, so followed the process in the link and it did work fine, the only problem is i was up till 4am with this one and in a minute of madness i gave up and formatted the laptop to start again so now i have the wonders of updating windows again. Many thanks for your help IronFly.

    All1
Sign In or Register to comment.

Who's Online in this Category1

Signis
Signis

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.