Examples: Monday, today, last week, Mar 26, 3/26/04

Acer aspire S7 won't shut down

JensoqvistJensoqvist Posts: 11Member

Tinkerer

Hi, 

 

My acer asprire s7 won't shut down propertly. The screen goes black but the led is still blue and the fan i still running. I have found a fix for the problem, and that is throught the windows updater repair-tool in the control panel. That fixes the problem for that one time, the laptop shuts down like it should. But next time I start the laptop and try to shut it down it doesnt work (If I am not doing the windows update repair tool-thing again).

 

Can someone give me some ideas how to fix this? I am using windows 10. 

 

FAQ & Answers

  • try to turn off windows startup:

    https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html

     

    check if this shutdown your Laptop complelty:

    windows logo key

    type command

    right click command prompt and choose to run as administrator

    on command prompt

    type

    shutdown /s /f /t 0

    I'm not an Acer employee.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • doughjohndoughjohn Posts: 353Member Enthusiast

    Hi

     

    For shut down problems I ensure that

    image

    all my boxes are empty.

     

    And I have made a desktop shortcut to shutdown, just in case.

    image

     

    You can use the command line.

     

    C:\WINDOWS\system32>shutdown

     /i         Display the graphical user interface (GUI)

     /f         Force running applications to close without forewarning users.

     

    and lots more.

     

    Hope this helps.

     

    Errr   Ironfly beat me to it with a comprehensive answer, but hopefully mine is prettierSmiley Wink)

  • JensoqvistJensoqvist Posts: 11Member

    Tinkerer

    Hey, I have tried what you wrote. Seems like it shutdown properly some time and some times not. Now it was working 4 times in a row just with a regular shutdown in the graphic interface, yesterday it didn´t. 

  • JensoqvistJensoqvist Posts: 11Member

    Tinkerer

    I have found out that the problem only exist when I use the extra HDMI/VGA-adaptor. Anyone have any idea what to do? Really frustrating to not be able to shut down the computer properly when I have it plugged in to my projector at home or a big screen when I work. 
  • JordanBJordanB Posts: 3,083ACE Pathfinder
    edited November 2017
    @Jensoqvist

    If you have the Haswell-ULT version of the S7-392 and your computer originally came pre-installed with Windows 8 or Windows 8.1, some people have used the Windows 8 Intel Management Engine driver as a workaround for the shutdown hang bug in Windows 10.

    I don't have a S7-392, but I am familiar with the bug.  Another option is to go back to Windows 8.1.

    https://www.microsoft.com/en-us/software-download/windows8

    Drivers are in link below.

    https://www.acer.com/ac/en/US/content/drivers

    You can get your original recovery media from Acer if you forgot to create a factory recovery drive and don't want to use vanilla Windows 8.1.

    https://us-store.acer.com/erecovery/rcd/

    There's a slight chance you could still reset your PC to factory condition if your Windows 8.1 recovery partition is still intact.

    https://www.youtube.com/channel/UCc2wrPP5__2PazgxybrgNKw
    I'm not an Acer employee.
  • JensoqvistJensoqvist Posts: 11Member

    Tinkerer

    JordanB said:
    @Jensoqvist

    If you have the Haswell-ULT version of the S7-392 and your computer originally came pre-installed with Windows 8 or Windows 8.1, some people have used the Windows 8 Intel Management Engine driver as a workaround for the shutdown hang bug in Windows 10.

    I don't have a S7-392, but I am familiar with the bug.  Another option is to go back to Windows 8.1.

    https://www.microsoft.com/en-us/software-download/windows8

    Drivers are in link below.

    https://www.acer.com/ac/en/US/content/drivers

    You can get your original recovery media from Acer if you forgot to create a factory recovery drive and don't want to use vanilla Windows 8.1.

    https://us-store.acer.com/erecovery/rcd/

    There's a slight chance you could still reset your PC to factory condition if your Windows 8.1 recovery partition is still intact.

    https://www.youtube.com/channel/UCc2wrPP5__2PazgxybrgNKw
    Ok, thank you. So the problem is with the Intel Management Engine driver for windows 10. I will try to install Intel Management Engine driver for Windows 8 if I can't find any better sollution. It's really annoying. Shouldn't Windows update or Acer solve this so you can use their hardware with windows 10?
  • JordanBJordanB Posts: 3,083ACE Pathfinder
    edited January 15
    By the time Windows 10 was released in July of 2015, most computer companies (including Microsoft and Intel) had already moved on to Broadwell-ULT and were working on Skylake.  Haswell was officially a Windows 8/8.1 computer.  Computer manufacturers had already caved in and updated a lot of their Haswell computers to work with Windows 7 (added legacy and CSM support), because of the consumer revolt over Windows 8.

    My only guess(es) as to why they didn't fix it......

    A. Too expensive to fix and test (those engineers get payed really well)
    B. Haswell-ULT and Haswell in general was a poor seller (not many units sold) ---It was tainted by Windows 8/8.1
    C.  If they did try to fix it through a UEFI update, they could be opening up a can of worms since it would need to run both Windows 8.1 and Windows 10.  Since the product was sold with Windows 8 or 8.1, their only real obligation was to make sure Windows 8.1 works properly. 
    D.  All of the above 

    The bug was first reported in August of 2015.  Since it's January 2018, I don't think you'll be seeing an official fix from Acer, Intel, or Microsoft.  That ship has sailed.

    As far as I know, the bug only affects Haswell-ULT computers.  I don't think it's just an Acer problem....as HP Haswell-ULT computers were affected as well.

    ULT=Ultra Low TDP 
    TDP=Thermal Design Power


    I'm not an Acer employee.
  • JensoqvistJensoqvist Posts: 11Member

    Tinkerer

    JordanB said:
    By the time Windows 10 was released in July of 2015, most computer companies (including Microsoft and Intel) had already moved on to Broadwell-ULT and were working on Skylake.  Haswell was officially a Windows 8/8.1 computer.  Computer manufacturers had already caved in and updated a lot of their Haswell computers to work with Windows 7 (added legacy and CSM support), because of the consumer revolt over Windows 8.

    My only guess(es) as to why they didn't fix it......

    A. Too expensive to fix and test (those engineers get payed really well)
    B. Haswell-ULT and Haswell in general was a poor seller (not many units sold) ---It was tainted by Windows 8/8.1
    C.  If they did try to fix it through a UEFI update, they could be opening up a can of worms since it would need to run both Windows 8.1 and Windows 10.  Since the product was sold with Windows 8 or 8.1, their only real obligation was to make sure Windows 8.1 works properly. 
    D.  All of the above 

    The bug was first reported in August of 2015.  Since it's January 2018, I don't think you'll be seeing an official fix from Acer, Intel, or Microsoft.  That ship has sailed.

    As far as I know, the bug only affects Haswell-ULT computers.  I don't think it's just an Acer problem....as HP Haswell-ULT computers were affected as well.

    ULT=Ultra Low TDP 
    TDP=Thermal Design Power


    Ok, thank you. It seems like they lack customer focus somewhere in the chain of software development. I am dissapointed that I can't shut down my computer. 

    The only way to fix this seems to install old intel engine drivers for windows 8.1 then or live with it. 
  • JordanBJordanB Posts: 3,083ACE Pathfinder
    @Jensoqvist

    A couple weeks ago, I noticed that Microsoft did push out an optional Windows Update "Intel Management Engine Interface driver 11.7.0.1045" for some Windows 8.1 computers like mine.  I have been testing it with Windows 10 and so far it seems to be working ok for the most part.   I'm not sure if 11.7.0.1045 is compatible with your computer though as I don't have your computer model.
    I'm not an Acer employee.
  • padgettpadgett Posts: 3,913ACE Pathfinder

    Just a thought but have you tried turning off Hibernation ? This also turns off fast startup.

    Open a DOS box as administrator and enter powercfg.exe /hibernate off

Sign In or Register to comment.

Who's Online207

Acer-Dan
Acer-Dan
brummyfan2
brummyfan2
DerLauskop
DerLauskop
jazzlanena85
jazzlanena85
Kamalika
Kamalika
Rainy
Rainy
thunderresistant
thunderresistant
wis
wis
+199 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.