Compatible Windows 10 build for Switch SW5-111

stevebassstevebass Member Posts: 4

Hi

 

I've been trying to find a working WIndows 10 build for this laptop, the Aspire Switch SW5-111 which is listed here as a supported model:

https://www.acer.com/ac/en/MY/content/windows10-eligible-models

 

I've tried the July 2016 build which doesn't pick up the touchscreen, audio, g sensor or the power management. The Platform drivers on the Acer site fail to install (tried in safe mode too) and the seperate audio driver also has no effect. The only thing I haven't tried is a BIOS update.

 

From looking at other posts it seems that Windows 10 Anniversary edition isn't supported and when I spoke on Live Chat I was told this model isn't compatible and to roll back to WIndows 8.1 (who on the planet wants to do that?) despite it being listed as WIn10 friendly on Acer's site. Seems ridiculous that a convertible doesn't play nice with the only operating system which suits the tablet/notebook idea properly, is there any future plans for proper support?

FAQ & Answers

  • stevebassstevebass Member Posts: 4

     

     

    Managed to get everything working I think, had to clean install Win8.1, install the relevant Win8.1 Platform Drivers and also the wifi driver and then do the assistive technology upgrade:

    https://www.microsoft.com/en-gb/accessibility/windows10upgrade

    Don't do the upgrade from the factory image, it's filled with the largest haul of crapware I've ever seen,

    I would also not connect to the internet until you've installed the platform drivers. Good job Acer!

     

    After installing the new Win10 platform drivers everything is fully working, after letting Windows update everything however the G Sensor had stopped functioning. There was no auto rotation option in settings and no rotate lock option in the Action Centre panel. From Here I went into services.msc and set the Sensor Service and Sensor Monitoring Service to Automatic. I also made the following change to the registry:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AutoRotation

    Change the rotation value from "0"  to "1"

     

    That should do it, now adaptive brightness and auto rotation actually work with a fully updated WIndows 10, on a hybrid that works really well with that OS. 

  • stevebassstevebass Member Posts: 4

    Ok still having issues with auto rotation. The Sensor Monitoring Service stops immediately after starting, I have to edit the registry entry HKLM\Software\Policies\Microsoft\Windows\LocationandSensors\Disable Sensors from "1" to "0", however this will revert after one or two reboots.

     

    Is there any way to keep this setting?

Sign In or Register to comment.

Who's Online2.3K

egydiocoelho
egydiocoelho
Ernest991
Ernest991
Fiszczok
Fiszczok
Hank917
Hank917
IVAN_PC
IVAN_PC
kikozonasur
kikozonasur
Luiz_Fernando_1984
Luiz_Fernando_1984
Mindžago
Mindžago
Phil42000
Phil42000
rdulcey
rdulcey
rwm
rwm
SC86
SC86
younes5701
younes5701
+2.3K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers