image

Acer V15 Nitro Gets Slow on Low Battery

V15_OwnerV15_Owner Member Posts: 7

Tinkerer

I purchased an Acer V15 Nitro VN7-592G last week. It is the 16gb RAM model with the full HD display. I previously owned a Sony Vaio F series laptop, and had to sell it off due to a similar slightly similar issue where the CPU would throttle itself to 770 mHz on battery regardless of remaining batter level.

 

So far, I am grateful of the fact that my V15's i7-6700HQ can run at its turbo frequency, and doesn't lock its clock speed to 770 mHz on battery power provided the charge is greater than 40%, unless I switch to power saving mode.

 

However, only yesterday I observed that the computer would get extremely slow once the battery level drops below 40% due to the CPU throttling itself to 790 mHz according to RealTemp, and Windows Task Manager. I turned battery saver off, and changed the power mode to high performance where all CPU parameters were set to 100%. This had no effect, and the CPU just locked itself to 790 mHz unless I plugged in the laptop, and ran it again on battery power once I was at more than 40% charge.

 

I find this highly inconvenient since the primary reason why I sold my dated (and over-priced) Sony Vaio to purchase my first Acer machine was due to the Sony's poor performance on battery life, their (Sony's) lousy customer service, and the fact I needed a powerful machine with consistent performance whether being run off battery, or AC power since I plan on using the laptop away from the convenience of an AC outlet to edit, and convert high definition AVCHD videos that use up a lot of CPU bandwidth.

 

If you own a V15 series, please do report your findings on this issue, and please do let me know if there is a way I can disable this form of CPU throttling either through a firmware update, or by digging through the BIOS settings becuase it really defeats the purpose of spending more than $1,000 CAD on a flagship machine.

 

FInally, if this issue if not fixable, are there any reputable laptop 19 volt portable power banks available that can top up my battery?

Best Answer

  • V15_OwnerV15_Owner Member Posts: 7

    Tinkerer

    Answer ✓

    Good news! So I downloaded and installed Throttlestop 830 from TechPowerUp, launched it, disabled BD PROCHOT, turned it on, and the CPU no longer throttles even when under 40% battery power. However, you have got to have the application running in the background for the anti-throttling mode to kick in, and increase the CPU speed!

    Hope this helps!Untitled.png

FAQ & Answers

  • AdamLYsakAdamLYsak Member Posts: 1

    I have same problem on my VN7-592G-741S when CPU frequency is locked to 800Mhz when battery is below 40% which makes computer very slow or useless to some my applications.

    I tried every possible way to solve problem. But it looks like the problem is not in OS settings (Windows 10). I suspect this caused by BIOS/firmware where is some condition for set CPU clock to 800Mhz when battery is below 40%.

     

    It is there any solution how to fix this issue or it is this some technical limitation? Please give us some informations about this.

     

    It is really anoying using computer almost half time on battery with wih 33% max performance of CPU.

     

    Thanks

  • V15_OwnerV15_Owner Member Posts: 7

    Tinkerer

    Hello,

    Thank you very much for the reply.

     

    Unfortunately, I have not yet been able to come up with a solution to this pesky problem. However, I visitied the forums over at Lenovo Yoga, and as it turned out, one user had the exact same problem with his ultrabook where the CPU would throttle to 0.4 gHz once the battery went below 30%. One of the forum members reported that he managed to solve this throttling problem by installing the latest version of ThrottleStop (I believe it was Beta 8.0 or something), and disabling BD PROCHOT. This enabled his CPU to operate at its advertised frequency regardless of the battery level.

     

    However, I have not yet tried this method because I do not want to tinker with the firmware on my notebook, and end up with a corrupted BIOS. If you are confident enough that this will work, then please do proceed with this step and be sure to report your findings so that I may follow along.

    As I previously mentioned, I threw out my former Sony Vaio F series for the exact same reason where the CPU would limit its frequency to 770 mHz on battery power. And now, it seems as though my new notebook has the same issue.

     

    I find this highly unacceptable from Acer that their proprietary power saving algorithms are enabled at 40% battery. I don't know who came up with this idea, but 40% battery charge is not too low for me. If this kicked in at 20% battery, then that would be acceptable. But 40%? No way!

    If possible, do try to get an Acer employee/threaf moderator's attention to this thread, and if you want to, do record a video of this issue, and upload it on YouTube for the world to see what paying $1,400 CAD on a premium flagship got us.

     

    This thread deserves more attention than ever. If we do not find a solution, then I think I will have to sell this computer on Kijiji, and purchase a refurbished Macbook Pro. This is my first, and will definitely be my last Acer purchase if Acer does not come up with a solution. Smiley Sad

  • V15_OwnerV15_Owner Member Posts: 7

    Tinkerer

    Answer ✓

    Good news! So I downloaded and installed Throttlestop 830 from TechPowerUp, launched it, disabled BD PROCHOT, turned it on, and the CPU no longer throttles even when under 40% battery power. However, you have got to have the application running in the background for the anti-throttling mode to kick in, and increase the CPU speed!

    Hope this helps!Untitled.png

  • starstudiostarstudio Member Posts: 33 Troubleshooter

    Hi - I'm having EXACTLY the same problem as you - happens when the battery hits exactly 40% and pegs the cpu at 780-790 Mhz. It also started back in November as best I can remember. So there must have been an update that did this... Anybody at Acer know what's going on here?

     

    Here's my thread on the issue:  http://community.acer.com/t5/V-and-VN-Series-Laptops/Extreme-slowdown-with-battery-below-50-VN7-792G/m-p/492253#M15432

     

    Running ThrottleStop may work, but it could stop at any time with a MSFT or an Acer update.

  • danquintanilladanquintanilla Member Posts: 2

    Hi. I am also having the same issue with my V15 Nitro Black Edition. It's really annoying to have the CPU clock fixed at 0.8Ghz when in battery power and < 40%. The laptop almost become useless at that clock speed.

     

    Acer, any solution to this problem??

  • starstudiostarstudio Member Posts: 33 Troubleshooter

    Here is an updated version of my previous solution from my other thread on this issue: I've done quite a bit of research into this issue, and it's not something that Acer can "fix" easily. The slowdown behavior seems most prevalent to Skylake based laptops from Lenovo, Acer, and MSI. It is caused by a combination of Intel's, Microsoft's, and manufacturers' firmware/software. It's produced by overly conservative intentional core-parking and thermal throttling. I did two things to take control of my CPU back which worked great:

     

    As usual, if you do any of this - create a System Restore point beforehand. And also monitor your machine for excessive voltage/heat until you have confidence in your settings. Throttlestop can add a Mhz/CPU monitor on your taskbar!

     

    1. Installed Throttlestop Obsidian. It's a great piece of software that does everything it's supposed to do and is very well thought out. My only concern is that some update to Windows 10 or change in Intel firmware could blow it up. But we don't have much choice here...
     
    On battery now, I set Throttlestop "Battery" Presets to keep cpu at about 1.6 Ghz (using "Set Multiplier"). This is ample to maintain performance yet conserve power. There are 4 presets you can customize, and switch back and forth on the fly. In the Battery preset I also disabled Turbo to keep heat down, disabled Power Saver (which is the INTC/Microsoft hidden setting that throttles your CPU), and unchecked ProcHot. This gives me good responsiveness and does not generate excessive heat. But a great feature of Throttlestop is that you can also set an overheat "alarm" which will auto-switch to a lower power setting if the cpu exceeds a certain temp threshold. (Obviously this is not a gaming setting - it's for apps like Excel, web browsing, etc.)  Here's what it looks like:

     

    Obsidian.PNG

     

    2.   Now for tweakers - this ISN'T NECESSARY but if you want more control and are proficient enough not to blow up your registry:

     

    A couple of registry tweaks. These don't make any gigantic changes to your OS, they actually just unhide user options that are hidden in the regulardefault Power Plan's (Advanced) settings dropdown menus.  The first command unhides Intel's hardware resident Core Parking and the 2nd unhides the Windows OS-managed core parking.  Type (or paste) these into an elevated command prompt (no reboot required):

     

    powercfg -attributes SUB_PROCESSOR 0cc5b647-c1df-4637-891a-dec35c318583 -ATTRIB_HIDE

    powercfg -attributes SUB_PROCESSOR 8baa4a8a-14c6-4451-8e8b-14bdbd197537 -ATTRIB_HIDE

    After unhiding the setting controls, you can change them as you would like in your Power Plan's Advanced settings. In fact - immediately go there to check if the 2 new options show up. If they didn't - immediately undo your registry changes by changing the -ATTRIB_HIDE to +ATTRIB_HIDE and rerun the commands. Then figure out where you went wrong.  You can check these links for very detailed procedures:

    Disable_CPU_Throttling_in_Windows

    Core Parking and Skylake - Scroll about 1/2 way down page to :"Processor performance autonomous mode (Enable/Disable)"

     

    Once unhidden, setting my "Processor performance core parking min cores" to 100%, and Processor Performance Autonomous Mode to DISABLED - the PC response improved enough (without Throttlestop) that it still slowed, but was usable. Of course, this decreases battery life considerably. With Throttlestop installed, I keep my Processor Performance Core Parking Min Cores set to 50%.

     

    And for those who are interested - I did try revving up my cpu using Throttlestop:

    with tweaks2.png

     
     
  • danquintanilladanquintanilla Member Posts: 2

    Thank you very much Starstudio! I'll try this solution.

     

    Dan

  • starstudiostarstudio Member Posts: 33 Troubleshooter

    A couple of links on how to set up and use Throttlestop:

    Read 1st while setting up - https://www.notebookcheck.net/ThrottleStop-Primer.213140.0.html

    This is more details for later - http://forum.notebookreview.com/threads/the-throttlestop-guide.531329/

     

Sign In or Register to comment.

Who's Online590

Acer-Jose
Acer-Jose
Acer-Monica
Acer-Monica
Aly01
Aly01
donlboy
donlboy
HusseinElsaka
HusseinElsaka
NekoYami494
NekoYami494
NicholasV
NicholasV
PrfyVdlxSg
PrfyVdlxSg
Psychoxd
Psychoxd
trucmuche2005
trucmuche2005
William_mk2
William_mk2
xapim
xapim
+578 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers