Examples: Monday, today, last week, Mar 26, 3/26/04

aspire tc-705 usb 3 ports

I think there is a problem with the front usb 3.0 ports

usb 3 thumbdrives sometimes are not recognized by windows.

A couple usb 2 devices wont work in those ports - a kobo e reader keeps disconnecting, and a video capture device doesnt work at all

Is there a diagnostic app?

Should still be on warranty

Answers

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    My advice is to backup your important personal files and reset your PC to factory settings.

     

    But first, try to create a USB factory recovery drive by watching video below.

     

    https://www.youtube.com/watch?v=IfKn87nk0F4

     

    You can try to reset your PC to factory settings by watching the video below:

     

    https://www.youtube.com/watch?v=tin27LxnBEU

     

    If that doesn't work, you can try Alt + F10 Method

     

    https://www.youtube.com/watch?v=NuljT0a8F7I

     

    And there's other options:

     

    https://support.microsoft.com/en-us/help/12415/windows-10-recovery-options

     

    If you still have trouble, you can try to do a clean install of Windows 10 Anniversary like I did.  I don't have any problems.

     

    Edit: It's possible that the registry changes and other attempted fixes you made has adversely affected your computer.

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    No this has been a problem since I got the unit.

     

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    Ok sorry, I'm out of ideas.

    I'm not an Acer employee.
  • JordanBJordanB Posts: 2,489ACE Pathfinder

    So out of the blue today, I'm also getting the front USB 3.0 ports turning off and on...with Windows 10 Anniversary clean install.

     

    <<sigh>>

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    Interesting, however I think my problem dates before the anniv update. I never had a usb 3 port & wasnt sure if it actually was the port or the device.

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    I've used the front USB 3.0 ports on a regular basis for the last 2 years.  I didn't have a problem until 30 minutes ago.

    I'm not an Acer employee.
  • JordanBJordanB Posts: 2,489ACE Pathfinder

    I was able to get my front USB 3.0 ports working properly again.  I went to device manager and uninstalled the Nvidia graphics driver (I'm using a third party graphics card.).  I let Windows automatically download and install the graphics driver it wanted.  It's working fine again.

     

    My problem may be unrelated to yours.  On my other machine that uses HD4600, I didn't have any problems.

     

    uninvid.PNG

     

     

     

     

     

     

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    So after you uninstall the driver does the windows "found new hardware" immediately come up?

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    Just keep uninstalling your Intel graphics driver until you get the default microsoft driver.  Be sure to tick the box to delete the software.

     

    Don't worry, as long as you have an internet connection, Windows will automatically download the correct Intel graphics driver.  It might take up to 20 or 30 minutes for that to happen depending on your internet speed.  In the meantime, the basic Microsoft display driver will work fine.

     

    If you have any problems just restart your computer.  No worries. Be patient.

    I'm not an Acer employee.
  • JordanBJordanB Posts: 2,489ACE Pathfinder

    If uninstalling your graphics driver doesn't help, then the last thing I can think of is to uninstall the realtek audio driver and just use the generic Microsoft Windows 10 Anniversary audio driver.....which will be automatically installed after you uninistall the Realtek driver.

     

     The reason that I suggest that is because Microsoft no longer supplies a Realtek audio driver for your mainboard for Windows 10 Anniversary.  I'm not sure what that implies.  Maybe nothing.  But in the past Microsoft has always automatically given a Windows 10 Realtek audio driver.  However, with a clean install of Anniversary, they just give the new Anniversary generic audio driver.  Maybe Microsoft knows something we don't.  Smiley Wink

     

    realun.PNG

     

     Edit:

     

    And then you'll have the lastest microsoft audio driver for Anniversary....

     

    microsoftauddriv.PNG

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    Ok I uninstalled display & audio drivers, seemed to go ok.

    The USB also seems better, no problems with the kobo reader so far.

    However I dont understand why this would affect the USB. Shouldnt we have done this for the USB driver?

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    I'll hopefully have more time in a week or two to play around with it and try to pinpoint where the problem was.

     

    Anyway, glad it's working better.  

    I'm not an Acer employee.
  • JordanBJordanB Posts: 2,489ACE Pathfinder

    I've found something else interesting.

     

    When I orginally clean installed Anniversary on August 2nd, Microsoft automatically gave me an updated Realtek card reader driver.  It gave the one in screen shot below.

     

    cardreaderanniversarydr.PNG

     

     

    However, I did a new clean install, and now it says there's no compatible drivers for Anniversary for the Realtek card reader.  It appears they've pulled their card reader driver.  The Realtek card reader has a USB interface.  

     

    nocompat.PNG

     

    Not sure what it all means......haven't figured that out yet.

    For now, I'm just going to use the card reader driver from Acer's website (from 2015).

     

    2015crdrv.PNG

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    Thats the same driver Im currently running - 5-22-2015

  • JordanBJordanB Posts: 2,489ACE Pathfinder

    Thanks for that information.  That saved me a lot of time.

    I'm not an Acer employee.
  • JordanBJordanB Posts: 2,489ACE Pathfinder

    Is your computer still working ok?  I haven't had any more problems with the front USB.  I've kept two USB drives plugged in at all times.  No problems.  

     

    Just to let you know that I don't really have time to tinker with it right now.  If it happens again, I'll definitely dig deeper and see what I can find out as the root cause.  At this point, I'm guessing the root cause was Windows 10 Anniversary.  Smiley Wink

     

    Microsoft keeps rolling out bug fixes on a regular basis so I guess that's a good thing.

    I'm not an Acer employee.
  • wayne_hwayne_h Posts: 15Member

    Seems to be working ok. though I havent used it much.

    Thanks for keeping me updated on this issue

Sign In or Register to comment.

Who's Online119

Acer-Moses
Acer-Moses
Acer-Victor
Acer-Victor
Danny2430
Danny2430
Lanner_Falcon
Lanner_Falcon
+115 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Predator Gaming

Unleash the beast within. The Orion 9000 is built for legendary power with Ice Tunnel 2.0 cooling tech and room for up to five 120 mm fans on the front panel.