Examples: Monday, today, last week, Mar 26, 3/26/04

VN7-591G - Touchpad two-finger scrolling stops working intermittently after an S3(sleep) transition

OS: Windows 10 Build 1511
BIOS: 1.15
Synaptics Driver: 19.0.7.33

I restart the sytem. At this point, the touchpad is working without issue. I then close the lid on the laptop to initiate S3(sleep). I notice on of the LEDs on the right side starts blinking. I open the lid and press the power button to resume from S3(sleep). 2 out of 4 times two-finger scrolling stops working at this point.

Is there a new driver that fixes this issue? Is there a way I can submit a ticket directly to Acer without going through chat or phone #?

Reason I am avoiding customer support: Chat representative wanted me to disable driver verificication with full assurance that this will fix my issue. Disabling driver verification is only useful when the device is not working at all. I tried it and it failed to fix the issue.

The other reason I am avoiding customer support is that the end result is very likely an RMA, which will not fix the issue.

FAQ & Answers

  • philetusphiletus Posts: 4,428ACE Pathfinder

    If you're not upgraded to this bios, it could be the problem as this one has a fix for sleep and resume.

    BIOSAcerFixed system sleep and resume issue. Optimized BIOS default setting.1.154.9 MB2015/10/21Download
  • jose423jose423 Posts: 8Member

    I'm on BIOS 1.15. Issue is occurring on latest BIOS.

  • philetusphiletus Posts: 4,428ACE Pathfinder

    You have a Precision touchpad. You can confirm this,

    http://acer-in.custhelp.com/app/answers/detail/a_id/33949/~/windows-8.1-touchpad-settings

    If you turn it off, you should be able to configure it with Synaptics.

  • jose423jose423 Posts: 8Member

    Capture.PNG

     

    Touchpad is recognized as precision touchpad by OS. However, there is no option to switch it from precision touchpad. The only options are to enable/disable different guestures such as pinch to zoom, two finger right click, etc.

  • philetusphiletus Posts: 4,428ACE Pathfinder

    Right under "Your PC has a Precision touchpad 

    " is a "switch" to turn off the precision touchpad.

  • jose423jose423 Posts: 8Member

    The Touchpad option turns the touchpad on/off.

  • sharky25ksharky25k Posts: 473Member Skilled Practitioner

     

    This could be just a workaround and not a solution for your problem.

     

    If you enable the option to disable touchpad when and external mouse is connected, and you connect a USB mouse (of course when the touchpad scrolling is not working) and then disconnect the USB mouse does the scrolling work afterwards?

    I am thinking that somehow you force the windows to reload the driver. But I am not sure if this trick is working.

     

    I have my 591G in service so I cannot test it, but for me I don't recall this happening, it is true I am rarely using sleep

  • jose423jose423 Posts: 8Member

    Workarounds:

     - Disable/enable "HID-compliant touch pad" in Device Manager under Human Interface Devices. Works always.

     - Reboot system. Works always.

     - Do another S3(sleep) transition. Works sometimes.

     

    As for the suggestion, I don't have a USB mouse to test with. I do have a bluetooth mouse. I set "Leave touchpad on when a mouse is connected" to off. I then noticed that the touchpad stopped working and bluetooth mouse continued working. I turned off the bluetooth mouse and touchpad started working. I checked that two-finger scrolling works. I closed the lid until I saw the two-finger scrolling stop working (2 tries). So I went ahead and turned on the bluetooth mouse... and the touchpad continued working. Umm, lets leave this one alone lol.

  • sharky25ksharky25k Posts: 473Member Skilled Practitioner

    Well, I see that you are very good at finding bugs in drivers:-)

     

    The connection of an external USB mouse would mean that your touchpad is disabled so  probably with a USB drive the workaround would do the trick (since disabling and enabling solves the problem). I am so curious about this bug now, I cannot wait to get my 591G back from service to test it.

Sign In or Register to comment.

Who's Online211

Acer-Harvey
Acer-Harvey
Acer-Karp
Acer-Karp
Acer-Tim
Acer-Tim
ajay8069
ajay8069
Bean143
Bean143
Cyriix
Cyriix
Dummytest97
Dummytest97
egydiocoelho
egydiocoelho
Ersatz
Ersatz
henriquerpc
henriquerpc
JackE
JackE
Kno63
Kno63
MaClane
MaClane
MegaParsec
MegaParsec
Rosenstock
Rosenstock
steve972
steve972
Torben
Torben
+194 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.


Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.