Examples: Monday, today, last week, Mar 26, 3/26/04

Dolby digital turns off on call/audio settings etc

Hi all,

 

I have Acer VN7-591G that runs win 8. I have a problem with audio. Whenever I navigate into some options related to mic, my audio almost mutes. I noticed that Dolby Digital Plus just turns off. If I turn it on manually -- everything becomes fine.

 

So to reproduce this problem I can do several things: go to Skype->Audio settings or open Recording Devices with right click on my mixer, or go to any application's settings with microphone (like in any online game), or start a call via Skype with anyone.

 

Also that happens with multiple applications: I can start Spotify after KMPlayer is already playing something and one of sources will be almost muted.

 

I assume that I don't have Cortana, so that solution doesn't work for me.

 

Did anyone have/fix this problem?

 

Thanks

FAQ & Answers

  • philetusphiletus Posts: 4,428ACE Pathfinder

    Try this

    go to the volume icon and click Playback Devices.
    On the speakers click Properties and go to Advanced tab.
    Disable the Allow applications to take exclusive control.

  • VermiVermiVermiVermi Posts: 7Member

    Hey, thanks for your replay.

     

    I should have mentioned that I already tried that. So I have those ticks unticked for both speakers and micro, also I noticed that option 'do nothing' or 'mute all sounds' during calls doesn't have any effect on my sound. But I left it to 'do nothing'.

     

    Also I'm quite annyoed with a lag in sounds when I, for example, listen to Spotify and then I start video playback. Video has distorted sound for some time (up to 1 minute).

  • philetusphiletus Posts: 4,428ACE Pathfinder

     

    Have you updated to the latest bios and audio driver? You should make sure all your drivers are the latest.

  • VermiVermiVermiVermi Posts: 7Member

    This page http://panam.acer.com/ doesn't show any updates for BIOS for my laptop. Where can I get that update?

     

    For the audio driver -- yes, I'm using the latest one (also taken from that page).

     

    Thanks

  • philetusphiletus Posts: 4,428ACE Pathfinder

    I found this here

    http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/when-using-my-microphone-the-microphone-level/3b1578c4-caa4-4629-a4fc-2a3d97c3da95?page=5

     

    Step 1: Download the free nircmd utility from http://www.nirsoft.net/utils/nircmd.html

     

    Step 2: Run this command: nircmdc.exe loop 172800 500 setsysvolume 5899 microphone

     

    This command sets the microphone volume to 9% every 0.5 seconds. Refer to nircmd documentation for exact meaning of the parameters.

     

     

    3 comments down.

    This worked beautifully after I created my own batch file that properly accessed what *I* use as my mic, it contains:

     

    c:\nircmd\nircmdc.exe loop 172800 500 setsysvolume 589119 default_record"

     

  • VermiVermiVermiVermi Posts: 7Member

    I updated BIOS to 1.15 and tried that solution. That didn't work. Dolby Digital gets turned off, it doesn't change any settings of default playback device when I go to recording devices or open Skype audio settings. So I doubt that this will help me.

     

    Thanks for your help anyway.

  • sharky25ksharky25k Posts: 473Member Skilled Practitioner

    Hi,

     

    I know it is a stupid solution but actually, I tried it and it looks like it worked.

    Read the last post from this topic:

    http://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/dolby-digital-plus-keeps-turning-off-and-sound-is/b3060bbc-a577-4a29-8ba9-8bcb2dc19804?page=3

     

    I opened this topic almost one year ago. The point is that if you will do this, your Realtek HD audio drivers, will be replaced by generic microsoft drivers, which will remove also the Dolby feature (ye I know... stupid idea), but the volume of the system will not be lower, as dolby would be turned off (interesting...Smiley Indifferent) So basically you somehow will have a different set of drivers, without dolby, but with the same level of sound as dolby would be enabled.

     

    You can try it and of course, if you are not happy with this idea, you can always go to device manager, select the sound device and then in properties you will have the option to roll back drivers, which will put back the Realtek drivers.

  • VermiVermiVermiVermi Posts: 7Member

    None of above helped. During troubleshooting I have no such option. If I uninstall those drivers I'll have quite low sound, almost impossible to use.

     

    After all updates it got only worse. Now I can't have 2 sources of sound simultaneously. The one that comes later is distorted (option 'Allow exclusive control' is unchacked/disabled). And this is quite bad, to be honest. Sometimes it lags and even after several minutes of silence when I turn on Spotify/Youtube the sound is low. After 5-10 seconds it realizes that this is the only source of sound now and gives it full power.

     

    I always have to turn off one of the sources and wait for some time to have another source of sound playing normally. Sometimes I can't play a game and listen to Spotify, for example.

     

    And the most terrible thing is that 2nd source is not just low. It's distorted in some way. Like it plays from another room or something. I can't fix this by just adjusting volumes in mixer.

     

    I'm not sure what that is: Acer, win8 or hd realtek audio. But I'll probably avoid as many of them as possible in future.

  • VermiVermiVermiVermi Posts: 7Member

    Oh my... This even happens if I close one tab with youtube opened, open another one and start playing some video... The second video has distorted sound. This is really terrible.

  • VermiVermiVermiVermi Posts: 7Member

    And in some games it just turns off and the sound in game is **bleep**. For example, happens with Saint Row 3. Dolby digital just turns off.

     

    And I can't even contact the provider of this great software and their website doesn't have any information.

  • fernan120pfernan120p Posts: 1Member

    Sorry that did not work for me 

  • ven98ven98 Posts: 4,045ACE Pathfinder
    The issue with Dolby Audio turning off constantly cannot be fixed. It is Dolby's fault and much more Acer's fault for choosing Dolby which is not suitable for gaming laptops just for this reason. Every time when the laptop connects to new VoIP, Dolby Audio will turn itself off. The best way to avoid this is by uninstalling Dolby.

    In this thread I have posted a way to fix the problem about your speakers getting quite, when dolby turns off and it involves deleting/leaving dolby off all the time.
    http://community.acer.com/t5/Nitro-and-Aspire-Gaming/Aspire-VX-15-Dolby-Audio-problem/m-p/505145#M16491
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

Sign In or Register to comment.

Who's Online189

1GOG
1GOG
Acer-Jose
Acer-Jose
Alez_Curquejo
Alez_Curquejo
AnthonyArtDemegillo
AnthonyArtDemegillo
Deexalis
Deexalis
egydiocoelho
egydiocoelho
Hanna555
Hanna555
JustinLudlow
JustinLudlow
RGM007
RGM007
RodolfoMartins
RodolfoMartins
Tsukina22
Tsukina22
tugorditobello
tugorditobello
+177 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.