Acer Aspire E1-571G - Charging

murtaza12murtaza12 Member Posts: 4
edited December 2017 in Aspire, E and F Series Laptops

Hey everyone,

 

I have had my Aspire E1-571G for about 2 years now.

Specs:

i5 3230M

12GB RAM (1x4GB) (1x8GB) - 1333MHz (upgraded from original 4GB RAM)

WD 500 GB HDD (5400RPM)

Windows 7 Ultimate x64

 

It's started to develop an issue while charging, every time I plug it in, it does its normal beep and the charging light turns on and the icon shows that the laptop is charging. 

After about 30 seconds, it goes beep again, telling me that the charger has been unplugged (which it hasn't), it stops charging, the charging light and the light on the power begin blinking and the laptop stops charging.

 

Before the issue wasn't this annoying, I had to plug the charger in at a certain angle and it would charge fine. That doesn't work anymore.

It just stops charging after 30 seconds of me plugging the charger in.

 

I ordered a new battery after reading somewhere that it is a battery related issue. New battery and old battery show the same results. 

 

What could be causing the problem here?

 

I did a fresh install of Win7, deleted the battery drivers from Device Manager, rebooted so they'd re-install. Nothing worked. 

 

Any replies would be greatly appreciated.

 

 

Thanks.

Best Answer

FAQ & Answers

  • laurent_14laurent_14 ACE Posts: 9,231 Trailblazer

    Hello,

     

    Have you straightened the socket strip (DC-IN connector)? + center - strip

    France
  • murtaza12murtaza12 Member Posts: 4
    Could you please elaborate?
    How can I do this?

    I have disassembled the laptop before, just need a clear idea of what you're talking about.
  • laurent_14laurent_14 ACE Posts: 9,231 Trailblazer
    Accepted Answer

    Straighten lightly this part (see attachment).

    France
  • murtaza12murtaza12 Member Posts: 4
    I tried straightening it with a small screwdriver, I didn't apply too much pressure as I didn't want to damage the charging socket .
    After straightening them (there are actually two strips on my laptop), I reconnected the battery, made sure the laptop was turned off and connected the charger.
    The orange charging light is ON and the laptop is hopefully charging
    I will let it charge in this state for about an hour or more, once its fully charged, I'll power it on to see how it works.

    Thanks so much for the help!
  • laurent_14laurent_14 ACE Posts: 9,231 Trailblazer

    You're welcome

     

     

    If you want to replace the cable DC-IN, I give you the part number:

    Spoiler
    50.M0DN2.001 - CABLE.DC-IN.90W
    France
  • murtaza12murtaza12 Member Posts: 4
    I couldn't thank you enough!

    Laptop seems to be charging fine now, will take note of the part number in case I run into issues again.

    Smiley Happy
  • ReyKenobiReyKenobi Member Posts: 2

    I keep my charger plugged in all the time so the battery draining isnt an issue for me. My main issue with this was the beep tone that sounds every time the charger plugs/unplugs, and I was looking for a way to rid of that.

     

    I used the solution provided here, and straightened the pin(s). What I have noticed afterwards is that the power icon in the taskbar (Windows 8.1) still shows that the charger is plugging/unplugging every 30 seconds or so, but there is no beep tone and the LED on the front of the laptop doesn't change color from blue to orange, and this is confusing me even more. I mean, I got rid of the beep tone, so yay!, but it concerns me that the charger is plugging/unplugging every 30 secs according to windows.

     

    P.S.: If this needs to be a separate topic, please let me know. I am new to the forums.

  • miamiajonesmiamiajones Member Posts: 1 New User
    edited December 2017
    Hello,
    I have the same problem but I can't find attachment you are talking about. Can you help me please?
  • StarscreamStarscream Member Posts: 1 New User
    I have that issue too.does'not charging and power charging lights(orange,blue one) flashing synchronously. Anyone can help me?
  • mkbpowermkbpower Member Posts: 1 New User
    When İ have same problem, i replaced battery to new one, problem is solved. 571g sockets is problemless. Charger is good quality. You must change battery or test another battery from computer shop. 
Sign In or Register to comment.

Who's Online883

Acer-Ingrid
Acer-Ingrid
Alapinta
Alapinta
aphanic
aphanic
asad1man
asad1man
batmalin
batmalin
caloy
caloy
Cr1stoUs
Cr1stoUs
Dog
Dog
DOGSR4LOVE
DOGSR4LOVE
EduardoMagnus
EduardoMagnus
EvilSh0k
EvilSh0k
GAVIN00006
GAVIN00006
IVAN_PC
IVAN_PC
laurent_14
laurent_14
lukewarmsundae
lukewarmsundae
Manas022
Manas022
MattMB
MattMB
mva1973
mva1973
NATHAWN
NATHAWN
nevi
nevi
Ravikumarrak57
Ravikumarrak57
rwm
rwm
SAhsanSB
SAhsanSB
Sam31
Sam31
Shanobye
Shanobye
Shanthan_Spidey
Shanthan_Spidey
SHINSHIN
SHINSHIN
songs1writer
songs1writer
ttttt
ttttt
WilliamRibeiro
WilliamRibeiro
Éricorj
Éricorj
+852 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos