Replaced my Aspire V5-573P touch screen digitizer

After the install, the Acer logo appears then after about 8 seconds there are a couple lines then it goes blank. Any suggestions??IMG_1583.JPG

FAQ & Answers

  • philetusphiletus ACE Posts: 4,759 Pathfinder

    If you have or can get a remote display, connect it and see if you get good picture on it.

    You may have damaged the ribbon cable. They are pretty fragile. 

    You might open it up where you can gently  wiggle the cable while it's on and see if it changes.

Sign In or Register to comment.

Who's Online752

Acer-Carsten
Acer-Carsten
Acer-Erick
Acer-Erick
Adriano21
Adriano21
AldrinNT
AldrinNT
Aleni
Aleni
AngelPerez
AngelPerez
Balticum
Balticum
bijay135
bijay135
brummyfan2
brummyfan2
Cyriix
Cyriix
Daiky
Daiky
Dézil
Dézil
exxo_
exxo_
jrIII
jrIII
Kev0806
Kev0806
linda85
linda85
Osakushi
Osakushi
Oseiasfilho
Oseiasfilho
Ozie
Ozie
PaulK
PaulK
Quin_Armani
Quin_Armani
RAWAL
RAWAL
SAYEDUZZAMAN
SAYEDUZZAMAN
usama68
usama68
Zeiler
Zeiler
RAWAL
RAWAL
+726 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1311

Total Points:4252

Total Accepted Answers: 164

Leostat Mainframe Wrangler