touchpad stopped working after windows 10 S7-392

Bill2015
Bill2015 Member Posts: 2
edited January 2019 in Windows 10

S7-392

I installed the upgrade to the Synaptics driver to no avail.

FnT and Alt.7 don't work.

Any ideas?

«13

Answers

  • JordanB
    JordanB ACE Posts: 3,729 Pathfinder

    You downloaded the driver here? :

     

    http://us.acer.com/ac/en/US/content/drivers

     

    You may have to restart your computer. 

     

    If that doesn't work, you may have to update the BIOS on your computer....according to acer...

     

    http://us.acer.com/ac/en/US/content/windows10-eligible-models

     

     

    I'm not an Acer employee.
  • Thomheggi
    Thomheggi Member Posts: 8

    I have the same problem. Stopped working after I updated to windows 10. Have upgraded with the latest drivers, but that didn't fix it. I have Acer Aspire S7-392.

  • Abdul-F
    Abdul-F Member Posts: 1 New User

    I had exactly the same problem. I managed to solve it partiallly by downloading the Synaptics touchpad driver (Windows 10, 64-bit version). Follow these steps to "partially" solve the issue. Only pointing works now, and the buttons are still inacctive. 

     

    1- Download and install Synaptics touchpad driver.

    2- Restart your laptop. If the problem is solved, you're good to go. If not, do the following:

    3- Search for (Mouse & Touchpad settings) in the Start Menu and click on it. 

    4- Scroll all the way down and click on "Additional mouse options". A new winodow (Mouse Properties) with several taps will open.

    5- Click on the rightmost tap called (ELAN).

    6- Select "E-Lan Smart-Pad" from the "Device" box.

    7- Click on "Enable Device".

    8- If checked, uncheck "Disable when external USB pointing device plug in"

    9- Then click on "OK"

     

    As I said in the beginning, this only solved my problem partially. I am still not able to use the buttons on the touchpad, only pointing works. 

  • Thomheggi
    Thomheggi Member Posts: 8
    Thanks. But I did exactly as you mentioned but i need the right /left mouseclick buttons on touchpad to work so i decide to roll back OS to Win 8.1 until new drivers are available.
  • Alfaifi
    Alfaifi Member Posts: 1

    I had the same issue after downloading and installing Synaptics touchpad driver for Windows 10. Just do the following and the problem should be solved:

     

    1- Search for "Device Manager"

    2- "Mice and Other Pointing Devices"

    3- Right click "ELAN Input Device" and then "Uninstall"

    4- Restart Windows and the problem should be solved.

     

    Apparently, the updated driver was not necessary. Cheers Smiley Happy

  • Thomheggi
    Thomheggi Member Posts: 8
  • Headhunter06
    Headhunter06 Member Posts: 1 New User

    Following a thread from earlier Microsoft forums, this worked for me yesterday to restore trackpad function. Go to the Acer driver page for your computer. Download the intel IO chipset drivers for Windows 8.1. Run the setup for the driver in "compatability mode" and install. You will need to restart the computer. The computer will then recognize the trackpad as a valid device. Then download and install the Synaptics (or Elan) driver for Win 10 from the Acer support page and restart. If the trackpad is not immediatley active on the restart, hit Function F7. At least this fixed it for me.

  • Avery
    Avery Member Posts: 2

    Thank you so much Headhunter! I tried your method on my Acer E3-111-C0WA laptop as the touchpad was not working, and afterwards it works flawlessly now! I wonder why the new updated drivers don't include the previous version's details (since this seems to be a huge wide spread issue).

  • Bill2015
    Bill2015 Member Posts: 2

    Worked for me. Thanks

  • PeteMc
    PeteMc Member Posts: 2

    I have the E3-111 with Synaptics Touchpad and Windows 7.Did the Windows 10 upgrade and touchpad didn't work at all.Will this fix work for me also?

  • Avery
    Avery Member Posts: 2

    Yes this will fix the issues you have been having with the touchpad being broken. I have the same laptop as you and Headhunter's method fixed it 100%.

  • suprnova
    suprnova Member Posts: 6

    I cannot find in acer download section: 'intel IO chipset drivers for Windows 8.1.'

    I have Nitro VN7. Please help. Touchpad does not respond.

  • Bavega
    Bavega Member Posts: 30 Troubleshooter

    I had the same problem, albet on an Iconia W510. Since I could not even find the touchpad in Device Manager I tried System Restore, which worked.

     

    Just a thought if you do not succed with reintalling the drivers.

  • suprnova
    suprnova Member Posts: 6

    I tried reinstalling os already. Did nothing. Above was mentioned to instal  'intel IO chipset drivers for Windows 8.1'.

    It is supposed to be found in acer drivers section, but I cannot find it. Please help to locate it. Thank you.

  • tom3333
    tom3333 Member Posts: 3

    Having the same issue with a w510. Are you now running Windows 10 with the touchpad working?

     

    Did you do the Acer restore or Windows restore?

     

    Thanks. 

  • Bavega
    Bavega Member Posts: 30 Troubleshooter

    I used Windows System Restore on my W510. Already during the reboot the touchpad started to work again. It completed, which took quite some time, but ended with a notice that said System Restore failed. It said it could not restore the system since no changes was discovered. It worked, touchpad has worked since.

     

    The Acer drivers are part of a set that can be found if you check out the files available for download in the section for your unit. At least that is the case for the W510.

  • Natey2
    Natey2 Member Posts: 23

    I have a new Acer Aspire E 11 (ES1-111M-C72R),

    Touchpad seemed fine in Windows 8.1 (I used it very briefly).

    Upgraded to Windows 10, and now the touchpad works for a while then locks up.

    I have to use Fn + 7 , twice (to disable and then enable the touchpad) and it will work again, for a while.

     

    If I plug in a Microsoft mouse, the mouse works fine.

     

    The touchpad driver is flaky under Windows 10, I think.

  • Putiek
    Putiek Member Posts: 1

    hey

     

    I use acer Aspire V3-772G, had the very same problem after installing win 10. Touchpad didnt work almost at all. THe state it was in made it unable to use. I know a thing or two about computers and i struggled for some time... nevetheless updating all drivers didnt help and i went with final solution what i found mentioned somewhere only once - upgrading my BIOS version from 1.13 up to 1.15. And right after installing it all was working in first boot. So my advice - upgrade BIOS, and your touchpad will work like heaven again Smiley Happy

    You can find it in here after putting your acer SNID:

     

    http://us.acer.com/ac/en/US/content/drivers

     

    Cheers

  • TonyTD
    TonyTD Member Posts: 1

    Hello, don't know how your laptop working now on W10 & what touchpad driver you have. If you have Elan driver, update it & MS W10 will search the available one to update for U. Restart. Press Fn Key & F7 (or key has mousepad logo on it) together to see pointer locked or not. If it locked, press both keys again to unlock it. Open website, Use 2 fingers (not 1 like before) lightly slice (w/ tips of fingers) to scroll. Note, U don't need to put fingers at the edge of touchpad to scroll anymore. Hope it help U.

  • biker48
    biker48 Member Posts: 2

    I had the same issue and tried everything I could. Nothing worked. Resorted to using a mouse and for 2 weeks or more thats how I used my 7735. Today I wake up and to my surprise my trackpad now works without me doing anything. Has Microsoft sent an upgrade to solve this problem as it is not just Acers that have the issue? Can anyone else comment on whether they have their trackpad back? I worked in IT for 30 years and we always viewed these strange things as the manufacturer or software supplier downloading a fix but saying 'nope we haven't changed anything' so they do not get bad feedback for bad programming.