Acer Aspire ES1-111M mousepad problem solved

auntelvisauntelvis Member Posts: 1

FYI: I have an Acer Aspire ES1-111M, Windows 8.1, 64 Bit, brand new. On 5-15-15 I installed an optional Windows Update "Intel Corporation - Other hardware - Intel(R) Serial IO I2C ES Controller". This update disabled the laptop's mousepad, but the external mouse worked OK. I was not able to uninstall the update with the regular Windows Update program. I opened Device Manager, expanded System Devices, and found "Intel(R) Serial IO I2C ES Controller". I right clicked the driver, clicked properties, went to the Driver tab, and clicked Roll Back Driver. After restart, the mousepad works again. Maybe this information can help somebody else out there.

FAQ & Answers

  • srudenkosrudenko Member Posts: 1

    Thanks for posting this. I had the same exact issue but on a Dell laptop. Windows Update recommended the update for "Intel Corporation - Other Hardware - Intel(R) Serial IO I2C ES Controller" Published 05/13/2015. After installing it my Synaptics touchpad did not work properly and also the Serial IO I2C appeared with an exclamation mark in Device Manager.

     

    I rolled back the driver and everything is working fine again.

    Windows Update is once again recommending that update but I am disregarding it since it seems to mess things up.

Sign In or Register to comment.

Who's Online942

2inSD
2inSD
Acer-Monica
Acer-Monica
Acer-Samuel
Acer-Samuel
andr
andr
augustox91
augustox91
billsey
billsey
Creepeut
Creepeut
Cruise4fun
Cruise4fun
EvidentRecker
EvidentRecker
fredobrr
fredobrr
hobbyholly
hobbyholly
ircop37
ircop37
JayWalkerLeo
JayWalkerLeo
Jose_Manuel
Jose_Manuel
karl0101
karl0101
LinkSlotGacor
LinkSlotGacor
MarcB
MarcB
milsabords
milsabords
MThrone
MThrone
Powerknug92
Powerknug92
rwm
rwm
Wr3kLi5s
Wr3kLi5s
+920 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers