Examples: Monday, today, last week, Mar 26, 3/26/04

Synaptics touchpad problems

Hi Guys, My touch pad isn't working on my aspire E1-572P laptop. Windows 8.1 64.

 

I have deleted and re-installed the driver several times, still won't work, although the icon lights up when I press right or left button but nothing on the touch pad

FAQ & Answers

  • GastankGastank Posts: 4Member

    The Synaptics touch pad gestures are not working on my Aspire E1-572P, although I have tried loading updated drivers from both Acer and Synaptics. The problem may have started since I had a touch screen replacement done by Acer about 2 months ago. The touch pad works fine as a mouse pointer.

     

    I had an on line chat with an acer tech. but he suggested doing a factory reset, which I thought was a bit extreme so I thought I might try here first.

     

    Would be grateful for any help. Thanks

  • -Justin-Justin Posts: 2,362Member Seasoned Practitioner

    Gastank,

     

    Please visit our Drivers and Manuals page and download the Synaptics drivers for your unit.

    Uninstall the current installed drivers.

    Install the drivers you downloaded from our website.

  • GastankGastank Posts: 4Member

    Justin, You will see that in both of my questions I have stated that I have, on several occassions, deleted my Synaptics Touchpad driver and re-installed from the Acer web site and also Synaptics web site. I have also had an on line chat with an Acer technician, but he suggested that I did a factory reset, which I thought was a bit extreme, so I haven't tried that.

     

    I am a bit dissappointed in the lack of interest in my question and assume that it must have answered before to another persons question, but other than updating drivers I haven't seen anything else to try.

     

    Thanks for taking the time to look at my question.

     

     

  • ArsonBoy5996ArsonBoy5996 Posts: 3Member

    Hey Gastank, I fell your pain as well.

     

    I bought my Acer Aspire E1-472P-6860 about a month ago, and while the laptop is great, Im suffering from the same issue.

     

    My touchpad and gestures were working fine up until about 4 days ago, rougly around when I got another series of updates from microsoft for windows. My touchpad still works, but my gestures are long gone and I have no idea on how to get them back.

     

    I've tried downloading the ELAN drivers from the drivers page acer provides, but that didn't help at all, and now my tray icon just looks like this:

     Capture.PNG

    In addition to this, whenever I try to go and look at my mouse settings in control panel, the options pane for my ELAN options comes up blank, like this:

    as.PNG

    I'm at a loss for what to do as well, and I might even start my own thread after this post to try and get more help, as I'm literally fuming to try and get my gestures back after I JUST figured out how awesome they are.

  • slubell123slubell123 Posts: 1Member

    I just found the answer to my snaptics touchpad problems on my acer laptop. The answer that worked for me was simply holding the fn key and hitting F7. See the article shown below:

     

    "http://www.tipsnext.com/laptop/fix-synaptics-touchpad-cursor-issue/

Sign In or Register to comment.

Who's Online236

Acer-Jose
Acer-Jose
Alez_Curquejo
Alez_Curquejo
Anthony81
Anthony81
egydiocoelho
egydiocoelho
ichase
ichase
JackE
JackE
JLCx
JLCx
johnnyamaz
johnnyamaz
JRzdouff
JRzdouff
Nit
Nit
NITHINSABU
NITHINSABU
Scrapperchan
Scrapperchan
Sharanji
Sharanji
Tiffanieanderson
Tiffanieanderson
ZenViper
ZenViper
+221 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Acer Store Deutschland


KOSTENLOSER VERSAND - AUSGEZEICHNETER SERVICE

Facebook

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.