Acer Aspire E1-572G Bluetooth not working after updating to Windows 8.1

After upgrading to Windows 8.1 x64 bit, my bluetooth is not detecting and cannot be detected by other devices (my mobile phone). In device manager, I have NO yellow triangles with exclamation marks, when I search automatically for updates, windows says everything is up to date (see picture below) so everything seems fine and running. Bluetooth is on but after searching does not find devices (even if the phone is also on bluetooth). Would somebody please help me? Many thanks.

Bluetooth.jpg

 

Best Answer

FAQ & Answers

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    Windows key logo + R

    type

    services.msc

     

    check if Bluetooth service is started and marked as automatic start.

    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    Yes, it is Running - Automatic (Trigger Start).

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    Accepted Answer

    Uninstall the BT adapter, right click it on the device manager and select uninstall.

     

    then reboot and install this drivers from the Acer support:

    http://global-download.acer.com/GDFiles/Driver/Wireless%20LAN/Wireless%20LAN_Atheros_10.0.0.263_W81x64_A.zip?acerid=635187312656536562&Step1=NOTEBOOK&Step2=ASPIRE&Step3=ASPIRE%20E1-572G&OS=81P1&LC=en&BC=ACER&SC=PA_6

    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    Thank you very very much! Just to make sure I'm not doing something wrong, after unzipping the file from your link, I've got 3 folders: 1)BT_DriverOnly, 2)Install CD and 3)Wifi_DriverOnly. Should I run the .exe file from the folder 1)BT_DriverOnly (btatherosInstall.exe)?

     

    Also, when you say "Uninstall the BT adapter", you mean uninstall the first component (of the 3) that appears under Device Manager: Bluetooth USB Module (Driver Provider: Qualcomm Atheros Communications)??

     

    Sorry for all the stupid questions but I'm worried about going wrong Smiley Happy!

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    You can use the BT_driver only.

    But....you have an USB dongle?
    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    Sorry, I'm not sure I understand the question (I'm not a native English speaker). If you mean memory stick, yes, I have a few. Presently, I connect to a wifi router at home, I don't use an adapter. I apologize if that's not what you asked Woman Happy!

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    I mean if you have an external Bluetooth USB device.
    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    Yes, for my wireless mouse and it is working fine.

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    So, you had problems with the integrated BT module and you are using an USB BT dongle?

    If so, you first need to detach your USB BT, then uninstall the BT module in the device manager, install the BT drivers you downloaded, reboot.

    Then check if your integrated BT module is working.
    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    There must be something I'm doing wrong because I didn't manage to install the new driver. After I unistall  Bluetooth USB Module in device manager and I run the btatherosInstall.exe file from "D:\Kits Free\Acer Drivers for Bluetooth\WLAN_Atheros_10.0.0.263_W81x64\BT_DriverOnly\drivers_Win8.1\production\Windows8.1-x64\Bluetooth-Driver\btatherosInstall.exe" , nothing happened - it didn't install. As I am convinced that your solution is correct - I see that your version of the driver is WLAN_Atheros_10.0.0.263_W81x64 whereas mine is 8.0.1.302, I'll try to have somebody more knowleadgeable than myself do it for me via TeamViewer.

    Thank you very much for all your trouble and patience. And kudos too!

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    Thank you.
    By the way, since your wifi drivers are an old version, you can try to install both BT and wifi with the main installer.
    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    The main installer being under Install_CD folder, the setup.exe file? Is that correct?

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    Yep!

    I'm not an Acer employee.
  • CadenzaCadenza Member Posts: 8

    You are a life saver! I ran Qualcomm Atheros Installation Program (i.e. the setup.exe file in the Install_CD folder) and now I'm up and running all my bluetooth devices! Thanks a lot!

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer
    You welcome. Smiley Happy
    I'm not an Acer employee.
  • shehzeen1o2shehzeen1o2 Member Posts: 1

    I just registered to thank you ironfly. I had the exact same problem after downgrading to windows 8.1 from windows 10. i was so frustrated due to this but your solution did it all. Thanks bud.

Sign In or Register to comment.

Who's Online1.2K

Bhagat
Bhagat
CCAPRIA
CCAPRIA
Cesarbare
Cesarbare
CreeperRyan
CreeperRyan
Easwar
Easwar
FallenRiser
FallenRiser
Fisher_P
Fisher_P
Geon_vert
Geon_vert
KurtAlves06
KurtAlves06
LAFreitas
LAFreitas
omarbishr
omarbishr
vivi092005
vivi092005
Whydle89
Whydle89
XandCosta
XandCosta
Yibo_de
Yibo_de
+1.2K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1957

Total Points:6297

Total Accepted Answers: 245

Leostat Community Aficionado