Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

aspire battery won't charge

paddy1paddy1 Posts: 3Member

I have an Acer Aspire 5670 notebook, and I have pulled out my hair trying to get a new battery to charge. Help Please!!!!!!!!!!!!!

I have the latest bios update, but can't find bios update 3309 which is supposed to solve this issue. Running Win XP.

 

Thank you.

Answers

  • Joshua188Joshua188 Posts: 523Member

    when you put the battery in what do you see?

  • paddy1paddy1 Posts: 3Member

    When I press on the battery indicator on the task bar, it comes up saying unknown, charging 0%

  • Joshua188Joshua188 Posts: 523Member

    ok, try this. First power off the unit> then unplug the unit>take the battery out> Hold the power button down for 30secs> then put the battery back in and plug it up and see if the issue remains.

  • paddy1paddy1 Posts: 3Member

    Already tried that. Didn't work. Tried for 2 minutes too. No luck.

This discussion has been closed.

Who's Online111

greenleaflink
greenleaflink
ZACK80
ZACK80
+109 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Five Year Anniversary

Acer Community turned 5 years old this week! I would say that's a reason to celebrate!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1036

Total Points:570

Total Accepted Answers: 88

ven98 Seasoned Specialist