acer aspire 5750g memory upgrade

Options
MaoTin
MaoTin Member Posts: 6 New User

Hello,

 

recently Iv bought a new Kingston HyperX 8GB (2x4GB) 1866MHZ memory cards, however when i installed these cards they showed no changes from previous cards which were also Kingston 8gb (2x4GB) cards with 1330MHZ.

 

Is there a way how to get 1866MHZ activated instead of staying with default 1330MHZ, otherwise I have throwed away money.

Answers

  • JackE
    JackE ACE Posts: 44,635 Trailblazer
    Options

    What indication of no-change were you basing your conclusion on? Your machine can probably use even faster 2x4gb kit ram if it was available but not necessarily result in better performance. You might have been better off trying to see if your machine and OS could recognize and use a 2x8gb kit despite its advertized 2x4gb max.

     

    Jack E/NJ

    Jack E/NJ

  • IRBabuin
    IRBabuin Member Posts: 10 New User
    Options

    What kind of HyperX? Blue, Red, Black, PNP? There are several reviews on the web that show that HyperX PNP can make you RAM work faster, 1600/1866.

     

    http://www.legitreviews.com/kingston-hyperx-8gb-1866mhz-pnp-memory-kit-for-notebooks_1599/3

  • MaoTin
    MaoTin Member Posts: 6 New User
    Options

    I just needed a bios upgrade. When I did it it set an options to an auto detect, before it was default which was 1330 MHZ.

     

    Thank you for help.

  • brummyfan2
    brummyfan2 ACE Posts: 28,191 Trailblazer
    Options

    I do agree with JackE's suggestion of trying with 2x8GB ( some have succeded but can not gurantee that for you), reason being that your chipset HM65 only capable of 1600MHz, so even if you update the BIOS, I doubt very much you can achieve 1866MHz.

  • MaoTin
    MaoTin Member Posts: 6 New User
    Options

    Well, after upgrading bios and runing Aida it shows me that now I have 8gb ram with 1866MHz.

  • JackE
    JackE ACE Posts: 44,635 Trailblazer
    Options

    Good for you! Do you notice an improvement in performance and speed in use?

     

    Jack E/NJ

    Jack E/NJ

  • MaoTin
    MaoTin Member Posts: 6 New User
    Options

    Not realy, however windows performance tester, that one in computer properties and performance, it changed index for processor and graphics, it is weird.

     

    Processor was 6.7 now 6.8

    Memory was 7.4 now 7.4

    Graphics was 5.9 now 6.6

    Gaming Graphics was 6.5 now 6.6

    Disk was 5.9 now 5.9 It is also weird because, I changed my HDD too, same sieze, but technical spec. was lower, this one had to be better.

  • JackE
    JackE ACE Posts: 44,635 Trailblazer
    Options

    Perhaps you could adjust performance tool settings to see if they change one way or another. Let us know. Interesting stuff!

     

    Jack E/NJ

     

     

    Jack E/NJ

  • MaoTin
    MaoTin Member Posts: 6 New User
    Options

    Give me more tips what to do, because windows experience index shows only these final numbers, even if I rerun the assessment tool.

  • JackE
    JackE ACE Posts: 44,635 Trailblazer
    Options

    In the performance information and tools section there should be a item "advanced tools" in which you can tweak some parameters to see if they make any difference in the numbers. Microsoft also has a free performance toolkit for new computers http://www.microsoft.com/en-US/download/details.aspx?id=39982 . I don't know how much more this toolkit allows you to adjust performance parameters. Good luck.

     

    Jack E/NJ

    Jack E/NJ

  • MaoTin
    MaoTin Member Posts: 6 New User
    Options

    Thats for windows 8 I have windows 7, but Ill try to play with performance later.

  • JackE
    JackE ACE Posts: 44,635 Trailblazer
    Options

    Please note under system requirements that Microsoft's Win8 performance toolkit also works for Win7 in most ways. May be useful? May be not?  8^)

     

    Jack E/NJ

    Jack E/NJ

  • IRBabuin
    IRBabuin Member Posts: 10 New User
    Options

    Yeah, that's exactly the type of BIOS upgrade that I expect for my 5349 to allow me to use better spec (latencies and speed) memory....right now is stuck at 1066...

    Please show some printscreens form AIDA, do some benchmarks too, memory read/write from AIDA. Thanks.

This discussion has been closed.