Acer Aspire 7 - A715-74G: Dual-Boot: Linux erkennt nicht / does not detect SSD NVMe WDC PC SN520SDA

UserKRUserKR Member Beiträge: 4 New User
Hallo Communiy, Hello Community (English version bellow)

folgender Status ist beim Aufsetzen des Laptops erreicht:
  1. Windows 10 ist installiert (bisher ohne Verbindung zum Internet)
  2. Das BIOS wurde vom Auslieferungszustand 1.23 schrittweise auf 1.24, 1.27 und 1.28 auf den neuesten Stand gebracht. Hat problemlos funktioniert.
  3. Die BIOS-Einstellungen wurden für den Dual-Boot mit Linux angepasst:
    Fast Boot Disabled
    Secure Boot Disabled
    Boot Menue (F12) Enabled
  4. USB-Sticks zum Booten von Debian GNU/Linux 10 ("Buster") habe ich auf verschiedene Arten vorbereitet, es ist aber immer dasselbe Ergebnis:
    Wenn ich die SSD weiter partitionieren will, erkennt Linux nur den USB-Stick, ein Wechsel in die Shell (ash) zeigt mir unter /dev keine Geräte nvme*. Die SSD NVMe WDC ... wird nicht erkannt.
  5. Meine Internet-Recherche hat ergeben, dass hier vielleicht ein Timing-Problem vorliegen könnte und man es mit dem kernel parameter nvme_core.default_ps_max_latency_us=5500 versuchen könnte.
Ich schaffe es nur den Rechner unter Linux über ein grub-Shell zu booten, weil mit anderen Sticks grub zwar die SSD anzeigt, die Partitionen des USB-Sticks aber als unbekannt deklariert.
Aus grub heraus startet Debian GNU/Linux mit:
  1. set root=(hd0,gpt2)
  2. insmod normal
  3. normal
  4. insmod linux
  5. linux /install.amd/vmlinuz
  6. initrd /install.amd/initrd.gz
  7. boot
Es laufen viele Meldungen durch und danach komm ich in die Installationsroutinen, aber beim manuellen Partitionieren wird nur der USB-Stick angezeigt.

Wie muss ich den oben genannten kernel paramter nvme_... bei der Eingabe in der grub-Shell angeben, damit der Linux-Kernel dies berücksichtigt. Mit grub kenne ich mich nicht wirklich aus.

Vielen Dank und viele Grüße
-----
English version:

the following status is reached for installing the laptop:
  1. Windows 10 is installed (yet without any connection to the internet)
  2. The BIOS is updated from delivery status 1.23 in steps to 1.24, 1.27 and 1.28 to the latest version. Update was successful.
  3. The BIOS configuration was adapted for Dual-Boot with Linux:
    Fast Boot Disabled
    Secure Boot Disabled
    Boot Menue (F12) Enabled
  4. USB sticks for booting Debian GNU/Linux 10 ("Buster") were created with different tools, but the result is always the same:
    When I want to do the SSD partitioning, Linux shows only the USB stick. Going over to a shell (ash) there are no devices /dev/nvme*. The SSD NVMe WDC ... is not detected.
  5. My search in the internet showed, the there might be a timing problem and that a try with the kernel parameter nvme_core.default_ps_max_latency_us=5500 might be helpful.
I only can boot with Linux from a grub shell, because only then the file systems on the USB stick are detected correctly.
From grub I start Debian GNU/Linux with the sequence 1. ... 7. (see above)
Then Linux is bootet and the installation tool starts, but at the point of manual partitioning only the USB stick is shown, no SSD at all.
How do I need to type in the kernel parameter nvme_... from above in the grub shell, so that the linux kernel takes the parameter for booting.
Sorry, I am not familiar with grub.

Many thanks in advance and best regards






Beste Antworten

  • ralpppralppp ACE Beiträge: 4,594 Pathfinder
    bearbeitet April 2020 Antwort ✓
    Gleich vorneweg:
    Ich bin ein absoluter Laie, wenn es um das Thema LINUX geht!!!

    Nur so ein Gedanke:
    Ist im Bios der SATA Mode von "RST Premium with Optane" auf "AHCI" umgestellt - eventuell kann LINUX nicht mit Optane umgehen?

    Beim Bios Updaten brauchst du im Regelfall nur die aktuellste Version zu flashen - Zwischenschritte sind nur erforderlich, wenn du von Acer explizit dazu aufgefordert wirst. Die neuesten Versionen beinhalten immer auch die Änderungen der Vorgänger.
  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet April 2020 Antwort ✓
    Hi,
    in Ergänzung zu ralppps Ausführungen. Schau bitte in diesen Thread. Falls bei dir im BIOS keine Umstelloption von Optane auf AHCI angezeigt wird, beachte den Hinweis auf den Tastenshortcut "strg + s":



    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

Häufig Gestellte Fragen und Antworten

  • ralpppralppp ACE Beiträge: 4,594 Pathfinder
    bearbeitet April 2020 Antwort ✓
    Gleich vorneweg:
    Ich bin ein absoluter Laie, wenn es um das Thema LINUX geht!!!

    Nur so ein Gedanke:
    Ist im Bios der SATA Mode von "RST Premium with Optane" auf "AHCI" umgestellt - eventuell kann LINUX nicht mit Optane umgehen?

    Beim Bios Updaten brauchst du im Regelfall nur die aktuellste Version zu flashen - Zwischenschritte sind nur erforderlich, wenn du von Acer explizit dazu aufgefordert wirst. Die neuesten Versionen beinhalten immer auch die Änderungen der Vorgänger.
  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet April 2020 Antwort ✓
    Hi,
    in Ergänzung zu ralppps Ausführungen. Schau bitte in diesen Thread. Falls bei dir im BIOS keine Umstelloption von Optane auf AHCI angezeigt wird, beachte den Hinweis auf den Tastenshortcut "strg + s":



    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • UserKRUserKR Member Beiträge: 4 New User
    Hallo Community,

    herzlichen Dank für den Hinweis auf den SATA Mode, dies ist die entscheidende Einstellung im BIOS, die Linux (egal welche Distribution) zunächst mal verhindert.
    Damit ergibt sich für den Käufer eines Acer Laptops, der Dual Boot mit Linux erreichen will, wohl folgende Prozedur für die Inbetriebnahme:
    1. BIOS Einstellungen anpassen
      a. Supervisor Password setzen, damit man den Secure Boot deaktivieren kann
      b. Secure Boot auf Disable stellen
      c. F12 Boot Menu auf Enable setzen
      d. Mit "Strg s" die Umstellung des SATA Mode ermöglichen
      e. SATA Mode auf AHCI ändern
      f. Fast Boot auf Disabled stellen
      g. Neues Supervisor Passwort eingeben, dabei nichts eingeben, um das vorherige zu löschen, sofern man wieder zu "ohne Passwort" zurück will.
    2. Windows installieren
    3. Linux installieren
    Es ist schön, dass Acer eine Hardware baut bzw. bauen lässt, die mit Linux funktioniert. Es ist haarsträubend, dass sich die Anwender die Konfiguration mühsam zusammensuchen müssen. Allein ein Hinweis auf "Strg s" innerhalb des "IndydeH20 Setup Utility (aka BIOS)" würde schon mal viel helfen.
    Ich kann hier nur Acer ermutigen, eine kundenfreundlichere Dokumentation zur Verfügung zu stellen.
    Neuere Generationen von Usern achten mehr auf Security, Transparenz, Datenschutz, Open Source, ... Wer diesen Trend nicht aktiv mit gestaltet und daraus Vorteile für die Kunden aufzeigt, darf sich nicht wundern, wenn er Marktanteile verliert.

    Viele Grüße

  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    abgesehen von deiner aus meiner Sicht richtigen Beschreibung und auch für andere User, empfehle ich noch in diese Kurzanleitung reinzuschauen. wo beschrieben ist, wie man den Bootloader als "trusted for execution" festlegt. Die Anleitung bezieht sich zwar auf Linux Mint, kann aber so für fast jede andere Linux Distribution übernommen werden:
    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • lazulilazuli Member Beiträge: 4 New User
    Hallo Community,

    zunaechst herzlichen Dank fuer die detaillierte Anleitung zur Installation eines Dual Boots Windows 10 / Linux auf dem Acer Aspire 7 74G. Ich habe die Anleitung befolgt und im SATA-Mode AHCI erfolgreich Windows 10 und MX Linux installiert. Da mein Rechner beim Reboot direkt in Windows bootete, bin ich ebenfalls der Anleitung "Festlegung des Bootloaders als trusted for execution" gefolgt. Also rein ins BIOS, Secure Boot auf Enabled, unter "Select an UEFI File as trusted for execution" die Datei grubx64.efi ausgewaehlt und Name vergeben. Reboot um erneut im BIOS meinen Bootloader in der Bootreihenfolge an erste Stelle zu bringen.

    Beim Reboot bootete allerdings mein BIOS nicht mehr. Ich sehe nur noch einen Black Screen mit einem Cursor oben links. Mein Windows bootet problemlos, mein MX Linux bootet nicht. Es kommt die Fehlermeldung "Secure Boot forbids loading module from...". Der Versuch, ueber die Problemloesung in Windows in das BIOS zu kommen, endet im gleichen Black Screen. Mein Bootmenu F12 funktioniert noch. 

    Meine letzten BIOS-Einstellungen, bevor nix mehr ging: Secure Boot - enabled, Fast Boot - disabled, SATA-Mode - AHCI, F12 Bootmenu - enabled, Supervisor Passwort ist noch Set. Alle anderen Settings habe ich nicht angefasst.

    Hat jemand eine Idee, was passiert sein koennte und kann mir vielleicht helfen? Meine einzige Idee ist, das BIOS zu aktualisieren, aber ich habe sowas noch nie gemacht. Ich frage mich auch, wass das aktualisierte BIOS mit Default Setting SATA.Mode - RST Premium with Optane zu meinen beiden in AHCI installierten OS sagen wird.

    Vielen Dank schonmal fuer eure Hilfe
  • UserKRUserKR Member Beiträge: 4 New User
    Hallo lazuli,

    ich habe bisher bei den Acer Aspire 7 74G kein Secure Boot mit "trusted for execution" eingerichtet.
    Allerdings hatte ich nach meiner ersten Windows-Installation das BIOS ja von 1.23 schrittweise auf 1.28 hoch gehoben. Nach jedem BIOS-Update wurde neu gebootet, wobei Windows gestartet ist. Zu diesem Zeitpunkt war noch der SATA-Mode - RST Premium with Optane eingestellt.

    Wenn ein BIOS-Update den SATA-Mode auf RST Premium with Optane zurückstellen würde, dann könnte Windows nicht mehr booten. Eine Änderung des SATA-Modes nach der Windows-Installation führt meines Wissens immer zu "geht nicht mehr".
    Deshalb hätte ich erst mal keine Bedenken ein BIOS-Update unter Windows zu starten, um dann beim Reboot wieder ins BIOS zu gehen und dort den SATA-Mode zu prüfen und ggf. wieder auf AHCI zurückzustellen.
    Beim BIOS-Update den Laptop auf jeden Fall per Stromversorgung aus dem Netzteil und nicht aus dem Akku heraus betreiben, damit auf jeden Fall genügen Energie vorhanden ist.

    Ich hoffe, Du bringst den Acer zu Deiner Zufriedenheit zum Laufen.
    Viele Grüße
  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet Mai 2020
    Hi lazuli,
    ich denke das Problem ist entstanden, weil die Anleitung von einem Linux ausgeht, das einen signierten EFi Bootloader mitbringt (ist bei den meisten Linux Distributionen inzwischen der Fall). Wenn stimmt was hier beschrieben ist, nämlich daß das bei Linux MX nicht der Fall ist, hättest du den Secure Boot nicht auf "enabled" stellen dürfen. Ohne "UEFI-zertifizierten" Bootloader gilt für das UEFI Linux MX als nicht sicher (secure) und es verweigert den Bootvorgang.




    Es geht bei dir um das A715-74G? Da für den Rechner von Acer für das Flashen eines BIOS eine "WinFlash"exe Datei hinterlegt ist, weiß ich auch nicht, wie du das BIOS updaten sollst, wenn nicht aus einem laufenden Windows heraus. Bei einem neugeflashten BIOS musst du zwingend erst wieder von Optane auf AHCI umstellen, damit dein Linux wieder läuft (ist bei einem im AHCI Modus installierten Windows auch so, daß  erst  wieder manuell auf AHCI umgestellt werden muß).
    Ich hab hier leider keine Idee. Wenn sich niemand anderes meldet, der weiterhelfen kann, solltest du den Acer Service kontaktieren.
    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet Mai 2020
    Ergänzung: Ich habe gerade erst "registriert", daß dein Windows ja noch bootet. Dann müßtest du auch über die WinRe ins BIOS kommen und könntest den Secure Boot direkt auf "disabled" stellen. Geh in den Windows Einstellungen auf "Update und Sicherheit"> Wiederherstellung und klick "Erweiterter Start"> "Jetzt Neustarten" an.
    Du solltest nach dem Neustart in der Windows Reparaturumgebung angelangt sein und klickst dort auf Problembehandlung>Erweiterte Optionen> UEFI/Firmware Einstellungen und solltest so ins BIOS gelangen, wo du die Umstellung vornehmen kannst.
    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • lazulilazuli Member Beiträge: 4 New User
    Hallo ihr beiden,

    vielen Dank fuer die schnelle Hilfe. Das mit dem signierten - fuer MX Linux nicht signierten - EFI Bootloader war mir neu.

    In kurz: mein Dual Boot laeuft nun mit einem kleinen Aber.

    Details: Ich habe das BIOS mithilfe des von Acer bereitgestellten Programms auf die neueste Version aktualisiert. Beim Reboot dann mit F2 in das nun funktionierende BIOS, den SATA-Mode auf AHCI geaendert, F12 Bootmenue enabled und natuerlich den Secure Boot auf disabled gestellt. Mein trusted efi file mit von mir gewaehlten Namen war noch im Tab Boot zu finden. Das habe ich dann an erste Stelle gepackt. Und der Rechner bootete ins Grub. Beide OS lassen sich im Grub auswaehlen und booten normal. Sehr gut.

    @Jochen: ja, mein Acer ist ein Aspire 7 715-74G. Dein Weg ins BIOS ueber Windows hatte ich bereits ausprobiert und ergab den gleichen Black Screen mit Cursor. Hatte ich oben mit "Problemloesung in Windows" versucht zu umschreiben, aber das war anscheinend zu blumig. Daher gab es fuer mich keinen anderen Weg ins BIOS und somit blieb mir nur die Aktualisierung.

    Aber nun: beim Ausschalten des Rechners und erneuten Einschalten (NICHT beim Neustart) bootet Windows 10. Ein Blick ins BIOS ergibt, dass im Tab Boot der Windows Boot Manager nun "irgendwie" an erste Stelle gerutscht ist. Ich musste die Reihenfolge wieder aendern um ins Grub zu kommen. Eine kurze Suche im Web ergab, dass eine Loesung wohl sei, ein Supervisor Passwort im BIOS zu setzen und beizubehalten. Das habe ich getan und tatsaechlich bleibt die Bootreihenfolge bestehen.

    Vielleicht hat noch jemand eine Idee was hier los sein koennte. Die Loesung mit dem Supervisor Passwort finde ich, nun ja, auch sehr blumig.

    Fun Fact: in der urspruenglichen BIOS Version auf dem Rechner, ich glaube 1.08, war der Punkt SATA Mode noch sichtbar. In der aktuellen Version muss man den Punkt wie hier im Forum beschrieben mit STRG + s hervorzaubern.

    Vielen Dank.

  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet Mai 2020
    Hallo lazuli,
    ich kenne mich weder mit Dual Bootsystemen, noch mit Linux gut aus.  Als ich vor einem Jahr Ubuntu 18.4, das einen signierten und UEFI zertifizierten Bootloader besitzt, als Dual Boot System mit Win 10  bei eingeschaltetem Secure Boot installiert hatte (hatte ich nie deaktiviert), blieb Ubuntu auch permanent an der ersten Stelle der Bootreihenfolge. Wenn ich Windows booten wollte, wurde mir von Ubuntu diese Option angeboten:


    Ich schätze also, daß das Problem an dem deaktivierten Secure Boot liegt.
    Leider ist es meiner Erfahrung nach so, daß nur wenige Linux  "Cracks" hier in die Acer Community als "Helferlein" reinschauen. Insofern ist es fraglich, ob du hier einen guten Tipp erhältst.
    Gruß
    Jochen:
    Edit: Blöde Frage: Du hast schon, nach dem Setzen von Linux an die oberste Stelle der Bootreihenfolge, diese Einstellungsänderung mit der F10 Taste abgespeichert; oder?
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • Kno63Kno63 ACE Beiträge: 12,604 Trailblazer
    bearbeitet Mai 2020
    >Aber nun: beim Ausschalten des Rechners und erneuten Einschalten (NICHT beim Neustart) bootet Windows 10.<
    Was mir gerade noch eingefallen ist: Bei Linux Installationsanleitungen wird immer darauf hingewiesen, daß der Windows Schnellstart deaktiviert werden muß. Probier das bitte mal aus, möglicherweise ist dann das Problem schon gelöst:



    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • lazulilazuli Member Beiträge: 4 New User
    Hallo,

    vielen Dank fuer deine Ideen. Ich vermute auch, dass es am deaktiviertem Secure Boot liegt. Nun gut, wenn ich bei MX Linux bleiben moechte, dann muss es eben die Loesung mit deaktiviertem Secure Boot und aktiviertem Supervisor Passwort sein.

    Der Schnellstart in Windows ist bereits deaktiviert. Aber danke fuer den Hinweis. Bezueglich des Speichern meiner Aenderungen im Bios mit F10: ja, ich habe auch an mir gezweifelt und es extra noch einmal ueberprueft. Das Problem bleibt.

    Wenn Grub bootet, sieht es bei mir aehnlich wie bei deinem Ubuntu aus, MX Linux an erster Stelle. Mein Grub ist grafisch nur ein wenig aufgepeppter. Grub ist wie gesagt nicht das Problem, sondern die Bootreihenfolge im Bios.

    @UserKR: darf ich fragen, welches Linux du neben Windows 10 auf deinem Aspire 7 intalliert hast? Bin jetzt nicht wirklich an MX Linux gebunden. Bastel gerade auch noch daran, dass mein WLAN erkannt wird.


    Vielen Dank fuer den tollen Support.

  • lazulilazuli Member Beiträge: 4 New User
    Edit:

    @UserKR: gerade gesehen, dein Linux ist das Debian GNU/Linux 10 ("Buster"). Wer lesen kann, ist klar im Vorteil. 

Anmelden oder Registrieren, um zu kommentieren.

Wer ist online1.3K

Acer-Ingrid
Acer-Ingrid
arpijuv
arpijuv
bluepen61
bluepen61
brummyfan2
brummyfan2
Daniel95Ramírez
Daniel95Ramírez
dvaghel1
dvaghel1
GlasgowGaryH
GlasgowGaryH
Irene_Ponce
Irene_Ponce
JackE
JackE
JasonSysAdmin
JasonSysAdmin
LeoRodriguez10
LeoRodriguez10
Mic0S
Mic0S
NiclasSWIFT3
NiclasSWIFT3
Nishanth_N
Nishanth_N
Peppi2411
Peppi2411
RenanVilela
RenanVilela
Seba1a1
Seba1a1
Spiffek
Spiffek
ssmikey33
ssmikey33
teodorj
teodorj
Torben
Torben
vlado22
vlado22
XdxD
XdxD
+1.3K Gäste

Mach mit! Teile deine Erfahrungen mit uns!

Anscheinend sind Sie neu hier. Um zu beginnen, melden Sie sich an oder registrieren sich.

Neu hier?

So, welche Regeln gibt es hier? Alle Regeln finden sich in der Acer Community Endbenutzer Vereinbarung. Besuche unsere Willkommensseite für eine kleine Einleitung mit den am häufigsten gestellten Fragen und vieles mehr. Informieren Dich sich über das Acer ACE-Programm und bleibe auf dem Laufenden, was es Neues in unserem Blog gibt.

Hilfe von Acer