next@acer 2020

Acer Swift 1 SF114-32-P78E BIOS update / Linux Installation Problem

swift1ownerswift1owner Member Beiträge: 6 New User
Hallo Forum,

Folgender Sachverhalt:

Acer Swift 1 Notebook, Model SF114-32-P78E
Pentium® Silver N5000, 1.10 GHz, Quad-core (4 Core™), 4 GB Arbeitsspeicher  
gekauft: Ende 2019

BIOS / UEFI Version 1.07
Ohne installiertes Betriebssystem
Grub: Run Linux Linpus / Install Linux Linpus
Option: Linux Linpus über Medium zu installieren
Prompt: "[[email protected]/#]"

Ich beabsichtige ein Linux Debian Derivat anstatt Linux Linpus zu installieren.

Acer Forum Hinweise:

zu BIOS / UEFI: Es sollte mindestens BIOS Version 1.08 installiert sein.
"Acer does not provide support for Linux systems in this series, only for Windows 10. For several years now, Bios updates are only available via .EXE files and no longer under FlashBios."

Kein Bios / Uefi upgrade durchgeführt, da Acer Bios / Uefi upgrade Datei eine ".exe" Datei ist (BIOS_Acer_1.09_A_A.zip) und kein Windows installiert ist.

zu BIOS / UEFI: Es wurde empfohlen im Bios nach einem Bios / Uefi Update-tool zu suchen (nicht gefunden)
Es wurde ein upgrade im Bios empfohlen (Heise): Rechner neu starten > F2 > nach Update-Option suchen (nicht gefunden)

Settings:

Supervisor Passwort wurde gesetzt
Secure Boot: disabled
F12 Bootmenu enabled    (Boot Manager)

Ich habe auf mehreren Computern ohne Betriebssystem Linux zum Laufen gebracht, mit installiertem OS oder Live-System.
Das hier bekomme ich trotz Rescherche nicht hin.
Vielleicht kann mir jemand einen Hinweis / Link zur Lösung des Bios update / Linux Installation Problems geben. Kann auch gerne in Englisch sein.
Und natürlich bin ich kein Linux Spezialist :-)

Gruß swift1owner

Häufig Gestellte Fragen und Antworten

  • aldo22aldo22 Member Beiträge: 17 Troubleshooter
    bearbeitet 9. März
    Ich glaube nicht, dass du das BIOS updaten musst.
    Ich habe OpenSUSE LEAP 15.1 auf BIOS Version 1.07 installiert und habe keine Probleme damit.

  • swift1ownerswift1owner Member Beiträge: 6 New User
    Hallo Aldo22,

    danke für den Hinweis. Dann wäre zumindest ein Problem gelöst.
    Jetzt sollte ich nur noch wissen, wie ich das Debian vom pen-drive auf den Acer bekomme.

    Gruß swift1owner
  • aldo22aldo22 Member Beiträge: 17 Troubleshooter
    swift1owner schrieb:
    Jetzt sollte ich nur noch wissen, wie ich das Debian vom pen-drive auf den Acer bekomme.

    Wo ist das Problem?
    Ich kenne Debian nicht besonders, aber Live-Installations-Images haben normalerweise auf dem Desktop einen Link im Stil "Jetzt installieren" oder ähnlich.
    Diese Frage gehört dann aber eher ins Debian Forum. ;)
  • Kno63Kno63 ACE Beiträge: 9,008 Trailblazer
    bearbeitet 10. März
    swift1owner schrieb:
    Hallo Aldo22,

    danke für den Hinweis. Dann wäre zumindest ein Problem gelöst.
    Jetzt sollte ich nur noch wissen, wie ich das Debian vom pen-drive auf den Acer bekomme.

    Gruß swift1owner

    Schau bitte mal in diesen Thread mit Basisinformationen für die Installation. Da geht es zwar um Linux Mint und um Dual Boot, aber wie das Booten vom Stick funktioniert und wie man anchließend den Bootloader als "Trusted for execution" hinzufügt, sollte sich nicht von der Vorgehensweise bei Debian unterscheiden:
    Gruß
    Jochen
    Edit,ganz nebenbei und nur so als  Idee,falls du doch das aktuellste BIOS haben möchtest: Eine Windows Installation mit dem Media Creation Tool ist meiner Erfahrung  (inclusive Download und Erstellen des Sticks) innerhalb weniger als einer Stunde möglich. Dann könntest du (auch ohne Lizenzkey und aktiviertes Windows) eine neue BIOS Version aus Windows heraus flashen. Danach die Festplatte löschen und Linux installieren.
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • swift1ownerswift1owner Member Beiträge: 6 New User
    Eigentlich müsste die Situation bekannt sein, weil das Swift1 u.a. mit dieser Konfiguration ausgeliefert wird (oder mit Windows).

    Wie bereits beschrieben:

    Swift1 ohne installiertes Betriebssystem
    Grub bietet 2 Optionen: Run Linux Linpus / Install Linux Linpus über Medium (CD/USB).
    Das bedeutet, Linux müsste sich eigentlich auch mit 1.07 Bios/Uefi Version installieren lassen, weil Linux Linpus optional installiert werden kann.
    Option Linpus installieren endet mit prompt: "[[email protected]/#]"

    Pen-drive oder SD card wird bei F12 (Boot Menu) entweder nicht angezeigt, oder endet bei Auswahl und "Return" bei Grub mit den beiden o.g. Optionen.
    Wenn ich Installieren wähle lande ich bei "[[email protected]/#]"

    Ich konnte leider keine Infos finden zu der oben beschriebenen ootb Konfiguration, die es mir erlaubt:
    Swift1 Linux Installation über Medium (USB) oder
    Swift1 Linux installieren über "[[email protected]/#]"

    Gruß
  • Kno63Kno63 ACE Beiträge: 9,008 Trailblazer
    bearbeitet 10. März
    Schau bitte auch mal hier rein:
    Dein Problem könnte auch an dem "RST with Optane Modus" liegen!

    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • swift1ownerswift1owner Member Beiträge: 6 New User
    Hallo Kno63,
    vielen Dank für die Hinweise.

    "Bitte zuerst das UEFI beim Booten mit F2 aufrufen und folgende Einstellungen vornehmen.

    Unter Main:
    Network Boot = Enabled
    F12 Boot Menu = Enabled

    Unter Security
    Supervisor Password  festlegen

    Unter Boot
    Secure Boot = Disabled

    Die Einstellung speichern (F10-Taste).
    Lass jetzt bitte die Installation von Linux Mint durchlaufen."

    Auch mit den geänderten Bios/Uefi Einstellungen wird wird weder die SD card mit persistent Linux, noch der pen-drive mit Live-Linux erkannt (F12).

    Welche Änderungen verursacht "Control + S" im Bios/Uefi-Main-Tab?

    Gruß swift1owner
  • Kno63Kno63 ACE Beiträge: 9,008 Trailblazer
    >Welche Änderungen verursacht "Control + S" im Bios/Uefi-Main-Tab?<
    Sorry, aber das steht doch eindeutig im verlinkten Thread! :-)
    Falls bei dir im BIOS der IRST with Optane Controller als aktiv angezeigt wird,  solltest du auf den AHCI Modus umschalten, da die Linux Distributionen nicht mit dem Optane Controller klarkommen. Viele neue Acer Notebooks (wie im  verlinkten Thread das SF314-57) haben im BIOS nicht mehr (offensichtlich) die Option zu AHCI zu wechseln. Dafür muß man im BIOS bei geöffnetem Reiter "Main" die Tastenkombination ausführen, um von Optane auf AHCI wechseln zu können. Wenn bei deinem Notebook schon AHCI eingestellt sein sollte, kannst du das Ganze vergessen. Wenn dir ohne Tastenkombination der Wechsel auf AHCI angeboten wird, brauchst du den Shortcut nicht.  Auch hier nochmal, zur Erläuterung:
    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • swift1ownerswift1owner Member Beiträge: 6 New User
    Hallo Kno63,
    vielen Dank für die Hinweise.

    Stand der Dinge:

    Bios / Uefi Settings:
    Bios > Version 1.07
    Bios > Information: Modus: AHCI
    Bios > Main: Network Boot: enabled
    Bios > Main: F12 Boot Menu (Boot Manager): enabled
    Bios > Security: Supervisor Passwort: enabled / festgelegt
    Bios > Boot: Secure Boot: disabled

    - zweites Medium ("Linux") wird erkannt
    - im Bios > Boot als erstes Medium gesetzt
    - oder im Bios > Boot Manager (F12) als Startmedium gewählt

    Trotzdem wird immer Grub hochgefahren mit
    Option 1: Linux Linpus starten (ist nicht installiert), oder
    Option 2: Linux Linpus installieren
    prompt: [[email protected]/#]"

    Ich werde jetzt mal recherchieren, ob es vom prompt aus einen approach gibt, um eine andere Distribution zu installieren.

    Die vorgeschlagene Windows Installation Variante (z.B. für das Bios update) werde ich mir für später aufheben.
    Eigentlich hatte ich verstanden, dass Acer Linux-freundliche Hardware anbietet.
    Auf einem 64 bit / Uefi Schenker Notebook ohne OS hatte ich kürzlich keine Probleme Linux zu installieren.
    Möglicherweise scheitert die Linux Installation am fehlenden know-how im Umgang mit der vorinstallierten Acer Linpus Software,
    die trotz aller Einstellungen immer wieder hochfährt.

    PS: Das USB Linux-Live-System ist mit dem (Linux) MX Live USB Maker erstellt worden. Könnte es sein, das hierfür ein anderes tool verwendet werden sollte?
    Es ist weder Windows noch ein vollständiges Linux auf dem Notebook installiert.

    Gruß swift1owner



  • aldo22aldo22 Member Beiträge: 17 Troubleshooter
    bearbeitet 12. März
    Vielleicht mal eine andere Distribution testen?
    Wie gesagt, bei mir läuft OpenSUSE problemlos.

  • Kno63Kno63 ACE Beiträge: 9,008 Trailblazer
    Ich weiß nicht, ob folgende Empfehlung das Problem löst. Aber wenn ich irgendein OS neu installiere, lösche ich vorher die Systemfestplatte komplett (ich benutze hierfür den Diskpart Befehl "clean"). Müßte doch hier auch mit GParted funktionieren, dann könnte es keine Konflkte mehr mit dem Linpus Linux geben.
    >Eigentlich hatte ich verstanden, dass Acer Linux-freundliche Hardware anbietet< Es geht da ja meines Wissens weniger um die Hardware, sondern darum, was das UEFI zulässt. Und ich habe schon von Acer Notebooks gehört/gelesen, auf denen eine Linux Installation anscheinend nicht möglich war. Ich habe aber noch nicht gehört, daß es bei den Swift Modellen Probleme gab.
    Aber ich habe selbst nur minimale Kenntnisse von Linux, und wenn die Installation nicht so funktioniert, wie im verlinkten Thread beschrieben, kann ich nicht weiterhelfen.
    Gruß
    Jochen
    "...there's more to the picture than meets the eye...."
    _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)
  • swift1ownerswift1owner Member Beiträge: 6 New User
    Zunächst mal Dank an alle für die Hinweise. Das für mich Wichtigste ist dazuzulernen und meine Hard- und Software soweit wie möglich zu verstehen und selbst zu managen.

    Ich habe den Swift zu einer Instituts-IT-Fachabteilung bringen lassen. Den genauen Fix kann ich leider nicht nachvollziehen, da ich bei der Installation selbst nicht anwesend war.

    Es ging wohl im Großen und Ganzen darum, dass die Bios / Uefi Änderungen (dank eurer Hilfe) richtig waren.
    Meine drei pen-drives waren wohl nicht sehr hilfreich: 1 USB 2.0 mit MX Linux 19 / 64 bit - 1 USB 3.0 mit MX Linux 19 / 64 bit - 1 USB 2.0 mit Bios v. 1.09  

    Das Bios brauchte kein update. Die MX Linux Installation kann mit Bios Version 1.07 gemacht werden, wie aldo22 anmerkte. 
    Meine Versuche zeigten im Bios (F12 und F2 Boot) einen zweiten Datenträger an, aber es wurde immer Linus Linpus Light GRUB hochgefahren (nicht das  Linux Linpus Light Betriebssystem) 
    Auf den USB 3.0 pen wurde MX Linux Live mit dem tool "MX Live UBS Maker" von einem anderen, zuvor OS-freien Notebook aufgespielt. Hier hatte ich mit der Installation kein Problem!

    Für die Swift1 / Linux Installation wurde die ISO neu gezogen und verifiziert. Das Live System wurde mit einem neuen / anderen pen-drive erstellt.
    Es wurden wohl mein USB 3.0 MX Linux pen und der neue, zweite USB drive angeschlossen und angezeigt, also drei Datenträger.

    Es wurden beide pen-drives für den Bios Live-System-Start (F2 / F12) getestet. In beiden Fällen fuhr Linux Linpus Light GRUB hoch.
    Erst als die dritte Option gezogen wurde, Linux Linpus Light zu starten (mit eingesteckten pen-drives), wurde MX Linux-Live-System von einem der beiden USB 3.0 pens hochgefahren.

    Sollte sich die Sachge tatsächlich so abgespielt haben, fällt mir nur eines ein:
    No comment !

    Gruß an alle und der Hinweis, dass ich diesen Vorgang nicht als Lösungsoption für das zu Beginn beschriebene Problem sehe!
    Ich war schon auf dem Weg kno63' Option "Diskpart Befehl "clean"" auszuprobieren.
    Jetzt läuft das OS und ich habe natürlich keine große Lust nochmal alles zu löschen und neu aufzusetzen, was ich aber eigentlich tun sollte.

    great community :-)
    swift1owner
Anmelden oder Registrieren, um zu kommentieren.

Wer ist online1K

AaronHollie
AaronHollie
alexis130219
alexis130219
Ampier
Ampier
batmalin
batmalin
BlackCobalt
BlackCobalt
EdsonFerreira
EdsonFerreira
gcsandesh
gcsandesh
glamont
glamont
harveyg14
harveyg14
JustinianTheGreat
JustinianTheGreat
Pepe32
Pepe32
shalomsam17
shalomsam17
Tshewxang7
Tshewxang7
+1K Gäste

Mach mit! Teile deine Erfahrungen mit uns!

Scheinbar bist du neu hier. Wenn du mitmachen willst, Wähle eine der folgenden Optionen!

Neu hier?

So, welche Regeln gibt es hier? Alle Regeln finden sich in der Acer Community Endbenutzer Vereinbarung. Besuche unsere Willkommensseite für eine kleine Einleitung mit den am häufigsten gestellten Fragen und vieles mehr. Informieren Dich sich über das Acer ACE-Programm und bleibe auf dem Laufenden, was es Neues in unserem Blog gibt.

Hilfe von Acer