Ultra-Thin

Topic

Reply
dlo
Regular Visitor
dlo
Posts: 4

Windows 8.1 issues with S3-391 trackpad

I just upgraded to Windows 8.1 and my trackpad is now having multiple issues. I have the most recent ELAN drivers.

 

I can no longer click while typing, even though "TP Rejection" option is disabled in the ELAN control panel. There is a delay of about 1 second before my trackpad becomes clickable after I use the keyboard.

 

I also can no longer choose to not have "reversed" scrolling. I only have the option to entirely enable/disable scrolling.

 

1.png

 

 

dlo
Regular Visitor
dlo
Posts: 4

Re: Windows 8.1 issues with S3-391 trackpad

2.png

dlo
Regular Visitor
dlo
Posts: 4

Re: Windows 8.1 issues with S3-391 trackpad

http://superuser.com/questions/658095/using-keyboard-disables-touchpad-left-button-for-a-second-on-a...

 

It appears that there is hidden Windows setting that overrides the ELAN drivers and enables the touchpad delay. The solution at the bottom of the page fixed the first issue.

 

However, I still can't disable reverse scrolling in the ELAN control panel, and editing the registry doesn't seem to work.

Frequent Contributor
suniljp
Posts: 192

Re: Windows 8.1 issues with S3-391 trackpad

Uninstall the current elan driver from control panel program and features look for elan and uninstall it. Restart and download the latest driver from the below link and install it.

 

http://global-download.acer.com/GDFiles/Driver/TouchPad/TouchPad_ELANTECH_v11.6.27.201_W81x64_A.zip?... S3-391&OS=81P1&LC=en&BC=ACER&SC=EMEA_27

Established Member
ParthPtl
Posts: 26

Re: Windows 8.1 issues with S3-391 trackpad

hey you should try the Acer S7's drivers on S3 .. I am using S7's driver on my M5 and I have 3 finger flicks working

Visitor
extrajay
Posts: 3

Re: Windows 8.1 issues with S3-391 trackpad

[ Edited ]

I am having the same issue - I have the latest ELAN driver which I downloaded and installed from the Acer web site.

It is the same one you mention here - version 11.6.27.201 for Windows 8.1 64 -bit.

This latest update to ELAN has the reverse option always ON and is greyed out and you cannot unclick it, so I am stuck with using reverse scrolling (with 2 fingers) everywhere - in the browser and in apps.

With the old version - it let you check or uncheck this option so you had a choice - have a reverse for the scrolling or not have it. With the latest version of ELAN - it is greyed out and you can't choose...

You can only disable the 2-finger scrolling altogether, which I won't do.


I want to say that I updated to Windows 8.1 then I went to Acer's web site and updated BIOS plus all available drivers.

After doing all that - the problem descibed occured.


Also if you install the regular Synapsis software last (after ELAN) - ELAN won't work at all. So you have to install the regular Synapsis driver first, and after that you have to install ELAN's driver. Only then, ELAN will work and will start after reboot. But you can't change the reverse scrolling option!

 

Is this a Windows 8.1 override feature?

Anyone knows how to fix this problem?

 

My laptop is an Acer M5-481PT-6488 model.


Thanks.

Visitor
extrajay
Posts: 3

Re: Windows 8.1 issues with S3-391 trackpad

[ Edited ]

Hi everyone.

I figured this one myself!

 

READ - EASY FIX - EASY FIX - EASY FIX - READ:

 

First - this is for Windows 8.1, with updated BIOS also.

 

My laptop is an Acer M5-481PT-6488 model.

 

After updating to Windows 8.1, I went to Acer's web site and looked for new drivers for my laptop.

I searched my model and chose Windows 8.1 64-bit version, then I downloaded all available drivers and the new BIOS and installed the BIOS first, then started installing all the drivers.

 

This thread is for the ELAN touchpad driver.

From the Acer's web site I downloaded the latest version:

 

version 11.6.27.201 for Windows 8.1 64 -bit

 

 

I installed it with just pressing the Setup file. (You can click on the first Setup exe file in the main folder, or you can choose the 64-bit ELAN folder first, and there click on the Setup file to install, both ways are the same thing.)

 

The installation of the ELAN software overrides the regular Microsoft touchpad driver, or the Synapsys touchpad driver or the previous version of ELAN driver. The ELAN touchpad is the most sofisticated of all 3 and gives you the most features and options - the other 2 won't allow you the fancy tapping, zooming and scrolling options.

 

But the latest version of ELAN did NOT work as the previous one, not at first.

Everyone seems to have had some problem with it.

 

The main problem for me was I could not turn off the REVERSE scrolling option, so it was always on, and in the ELAN so called "Smart-Pad" settings menu the reverse scrolling was always checked and greyed out, so I couldn't uncheck it.

 

So after playing with it for over 2 hours I eventually found out why the option is greyed out, and how to fix it.

 

You have to open the ELAN Smart-Pad settings menu. Thereare 3 tabs on top - One-Finger, Multi-Finger, and Additional.

At first, under the Multi-Finger tab - and under "Scrolling" options - I could only check or uncheck "Vertical" and/or "Horizontal" scrolling. The other 3 options in this category - which are extremely important - were greyed out, and could NOT be changed. These 3 options are the "Scroll Speed" setting, and the "Internal Scroll" and "Reverse" options. The Scroll Speed was set to position 3 for me and the other 2 were checked. And I could NOT uncheck REVERSE - which was the most important thing to do for me.

 

So I played with the other settings and I found this - the above mentioned 3 options will no longer be greyed out and you will be able to change them if you do this:

 

Go to the 3-rd tab - "Additional" - and choose the last option to the left - "Gesture Effect"; there change the setting from "ZoomPerfect" to "Microsoft modern touchpad experience"; and then go back to the 2nd tab (Multi-Finger) and choose "Scrolling" again, and voila - now you will be able to change all the settings here, including the "Reverse" setting!

That was the simple fix!

 

Also, play around with the rest of the features and set them to your preferences!

 

I hope this helps!

 

Visitor
talhazubair96
Posts: 1

Windows 8.1 issues with S3-391 trackpad :

Windows 8.1 Issues with ELAN pointing device (version 11.6.8001 )

I have the same problem so can someone help me out. Whenever turn on my laptop, I have to click on mouse options then I click on "set all default". After doing this every time my touched works well but Iam frustrated by doing this so please help me out and Answer this ASAP. 

 

Visitor
onejon
Posts: 1

Re: Windows 8.1 issues with S3-391 trackpad

My even easier fix which seemed to miraculously work, was to 

 

- Go to Control Panel

- Go to Mouse

- Elan tab (for trackpad)

- press stop device

- use "touchscreen" on Acer S7 fortunatley, to press enable device

 

and so I think it just need restarting.  Installing new drivers probably achieves the same thing but the above took seconds and no faffing!  :smileyhappy:

Visitor
aspiringdude123
Posts: 1

Re: Windows 8.1 issues with S3-391 trackpad

SOLVED!!  extrajay's post fixed my issue:

 


extrajay wrote:

Hi everyone.

I figured this one myself!

 

READ - EASY FIX - EASY FIX - EASY FIX - READ:

 

 

 

The main problem for me was I could not turn off the REVERSE scrolling option, so it was always on, and in the ELAN so called "Smart-Pad" settings menu the reverse scrolling was always checked and greyed out, so I couldn't uncheck it.

 

So after playing with it for over 2 hours I eventually found out why the option is greyed out, and how to fix it.

 

You have to open the ELAN Smart-Pad settings menu. Thereare 3 tabs on top - One-Finger, Multi-Finger, and Additional.

At first, under the Multi-Finger tab - and under "Scrolling" options - I could only check or uncheck "Vertical" and/or "Horizontal" scrolling. The other 3 options in this category - which are extremely important - were greyed out, and could NOT be changed. These 3 options are the "Scroll Speed" setting, and the "Internal Scroll" and "Reverse" options. The Scroll Speed was set to position 3 for me and the other 2 were checked. And I could NOT uncheck REVERSE - which was the most important thing to do for me.

 

So I played with the other settings and I found this - the above mentioned 3 options will no longer be greyed out and you will be able to change them if you do this:

 

Go to the 3-rd tab - "Additional" - and choose the last option to the left - "Gesture Effect"; there change the setting from "ZoomPerfect" to "Microsoft modern touchpad experience"; and then go back to the 2nd tab (Multi-Finger) and choose "Scrolling" again, and voila - now you will be able to change all the settings here, including the "Reverse" setting!

That was the simple fix!

 

Also, play around with the rest of the features and set them to your preferences!

 

I hope this helps!

 


 

Welcome, Guest

Not A Member?   Register
Help
Language:
Member Highlight

Acer is proud to announce the promotion of Philetus to the ACE team. Philetus has been a member since March 2013 and has shown the skills and patience required to be a member of this exclusive, invite only team of experts. Congratulations Philetus!

ACE Pioneer

Did you know?

Acer Community is also available in the following languages: