2014 Archives

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.


Posts: 4

Iconia A500 frozen at Acer logo boot screen

Another person posted something re: their A100, and the symptoms were similar.  I'm hoping someone has had a similar experience with their A500 and recovered.  


I have an A500 refurb unit, running factory ICS software (non-rooted) that is frozen at the ACER logo boot screen.  


Unfortunately, I have not had any luck recovering it, and mine is apparently out of warranty.


The issue arose, when I was trying to back out of a game that my son had started, and, once at the home screen, I started getting repeated program crash errors (i.e. Laucher has stopped working, wait/close, Agent Dash has stopped working, wait/close, etc).  I tried clicking "close" or "ok" (can't remember exactly what the question was), and it ended up running through a list of apps that had been opened at some point or another, while continuing to comeback to the Launcher has stopped working error.


I tried powering down, then powering back up, and the Acer logo screen is as far as it will go.


I have tried the hardward reset, and it apparently succeeds in Erasing User Data and Cache, showing the messages on-screen, but then freezes on the ACER logo.  


If I try to boot into recovery an load the update.zip from the SD Card.  It looks as if it is trying to update (upright Android bot with polygonal prism rotating in open chest, and blue update line below), then the screen flashes to a "dead Android bot" with a red exclamation point above his chest.


It looks like USB bootloader mode works, but I don't have anything on my PC to try and utilize that.  Or, at least I'm not aware that I do.


My hope is that, if anyone has had similar experience, then possibly, there is an issue with Acer's OS update (possibly due to poor memory management) that is causing corruption in the OS-- maybe calling an erase memory sub-routine erroneously, and it is affecting the flash with the OS.  (Long shot, I know.)  If so, maybe they would be willing to reflash the out-of-warranty units for free, or, at least, for the cost of shipping.


If there are methods that anyone has tried successfully to remedy this, I'd appreciate any advice.  If there are files available to load onto the SD Card or for use with the USB bootloader mode, I'd appreciate being pointed in that direction.

High-End Contributor
Posts: 684

Re: Iconia A500 frozen at Acer logo boot screen

I've sent you a private message to help you further with this issue.

Important Links: US Driver Downloads | Knowledge Base Articles | Service Locations
Remember to mark posts that resolved your issue with Accept as Solution.
You can even mark multiple posts in a single thread. This will make it easier for others to find the same information.

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

I'm having the same problem with my A100 Iconia Tablet, only I never got any error mesages or anything - I just turned it off one day and it would not boot back up the next.  I've tried to reset it, and it goes as far as the Android logo while booting up and then freezes there.  Please help!

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

I'm having the same issue with my A500. Boots and stops at the android logo. Have done factory reset, pressed reset button...still no joy. Any advice would be helpful.

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

I am having exactly the same problem as headache joe except I literally started it up one day nothing new installed and stuck on acer book screen tried holding power and volume key etc nothing just out of warranty. I have only had this for a year any help would be appreciated.

Wont even work on reset. 

New User
Posts: 1

Same Problem

I have literally had the exact same problem as everyone in this thread, one day I just powered it up and it just stayed at the Acer boot screen until the battery died.

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

Same happened to me on 14th of December. Tried everything from rebooting to factory-reset. Nothing works. Found out that i run ICS-bootloader V0.03.12 although I can't remember updating to ICS? Something went wrong at that point? I know my tablet was busy updating when te problem occurred.


Is there a simple solution to this problem or do I have to sent in my Tablet to the nearest Acer Repair Center (if there is one in the Netherlands)?

Please reply.

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

I just experienced the same problem.  Everything was fine, turned off the tablet, and later, when I turned the tablet back on, it never got past the "Acer" screen.  I've tried the recovery option -- power on while holding the volume+ button -- several times and keep getting the Droid on his back icon with the exclamation point.


The A500 is running Acer-supplied 4.1 O/S and only apps downloaded from the Play Store.



Any ideas?  Thanks in advance.

New User
Posts: 1

Re: Iconia A500 frozen at Acer logo boot screen

I had the same problem with my Acer Iconia A100.  I was playing a game I frequently played and then the tablet just shut off and wouldn't re-boot. Stayed stuck on the Android logo. My A100 was running ICS non-rooted.

I had to send mine in for repair and they replaced the main board, however I am still having issues with the A100 maintaining a wifi connection. This has been ongoing since day one.

When I received unit back it had been re-set and I had to do all the system updates and when it was doing the ICS update the wifi connection was lost at 37% of the download.

The tablet seems to be working o.k. now except for the wi-fi issue and I am planning to send it back since they did not address that issue as I had requested. (I don't even think they read the paperwork I sent in with the repair) When I called them to find out why the wi-fi was not corrected they said the repair order only stated "tablet won't boot".  

New User
Posts: 2

Re: Iconia A500 frozen at Acer logo boot screen

I am having the same problem as headachejoe, I turned off an app and my tablet booted to the Acer logo and that's all it will do now. The image recovery goes to a prone android bot with a red triangle with an exclamation mark in it. Please tell me what I need to do.

The unit is out of warranty as of May of this year.

Any help will be greatly appreciated.

Service and Support Videos
Welcome, Guest
Not A Member? Register

Join the forum discussions on our Predator line of products.

Member Highlight

It’s time to recognize brummyfan2 for his dedication and collaboration. Please join us in welcoming brummyfan2 to our ACE Team! brummyfan2 has been a valued member of the Acer Community since 2013, eagerly helping users troubleshoot their products.

Cheers !

Total Posts Written: 751
Total Kudos Received: 121
Solutions Accepted: 53

ACE Pioneer

Did you know?

Acer Community is also available in the following languages: