This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.


New User
Posts: 2

Aspire S3 won't boot from USB flash drive


I brought an Aspire S3 today to replace my ageing Vaio but I can't get it to boot from my USB drive.

The S3 arrived with Win8 which works fine and sees any USB drive I connect to it. However when I try to opt from a bootable one it just goes straight to Windows.

The USB drive is definately bootable and works perfectly on the Vaio.

I've gone through all the options in the BIOS (Insyde H20) and tried every combination of boot order. When I try the Boot Order key (F12) during POST only the internal HDD shows up.

Is there a known issue with booting from external devices on this device or am I missing something?

(Don't think it helps/makes a difference but the USB drive is a SanDisk Cruzer Blade 4GB, made bootable by YUMI and has 5 bootable OSes on which I need to be able to access.)

Many thanks
Posts: 21

Re: Aspire S3 won't boot from USB flash drive

Try legacy boot mode in BIOS.  In UEFI mode, the USB drive won't get recognized as a bootable drive.

New User
Posts: 2

Re: Aspire S3 won't boot from USB flash drive

I tried that but just get 'No bootable device -- insert boot disk and press any key'.

With this set, even if I go into the boot menu (F12) and choose the internal HDD with Windows on it gives the same message. It's like it refuses to boot from anything in Legacy Mode.
New User
Posts: 1

Re: Aspire S3 won't boot from USB flash drive

For those who have the same problem stated above... It's the BIOS. 


From the original default Windows 8 on Aspire S3, get the latest BIOS which is v2.17 (at the time of my post). Apply the new BIOS. Then access BIOS and turn off UEFI mode. Reboot. Now the BIOS will recognize your bootable USB (Windows, Linux, whatever)



New User
Posts: 4

Re: Aspire S3 won't boot from USB flash drive

How about this.....

I installed and set up Win 7 on a new internal new hard drive.
Had to use the "legacy" setting to get it to work.

Now I would like to set up the original hard drive

with Win 8.1 and boot from that original hard drive using a

USB connection.  Since the Win 8.1 drive "needs"

the "UDFI" setting to boot I don't see a way to
use the "UDFI" setting with the USB connection.

Does anybody know how to accomplish this?


I have tried the idea of disconnecting the Win 7

drive with no success.  Taking apart the case

to swap drives is getting old at this point.



Service and Support Videos
Welcome, Guest
Not A Member? Register

Join the forum discussions on our Predator line of products.

Did you know?

Acer Community is also available in the following languages: