2013 Archives

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.


Posts: 6
Accepted Solution

Windows 8 Upgrade // Touchpad Not Working Right - Acer Aspire V5 - 531



Ive upgraded from Win 7 Home Premium to Win 8 Pro using the Acer Windows 8 Upgrade Tool everything was completed successfully no issues at all last night but today ive turned the laptop on and my touchpad doesnt work right and the cursor is acting as if someone is swirling it around the screen.


So ive checked the acer website and theres no update for the Synaptics driver for my laptop so can someone explain to me what i do next as i know it was a synaptics driver from when it was windows 7 but at the moment its listed as a microsoft mouse driver and theres no way of updating the driver via the device manager options.



Established Member
Posts: 33

Re: Windows 8 Upgrade // Touchpad Not Working Right - Acer Aspire V5 - 531


You need Synaptics Touchpad driver

You can download it from here:



Then selecting Ultra Slim under groups then ACER V5 -531 DO NOT CHOOSE A 531-g/p or pg as the synaptics driver may not be on their page !!

Download the file run it as administrator THEN RESTART and hey presto your driver is back working again

Whilst this driver is a windows 7 one it works perfectly well under windows 8 !!

Posts: 6

Re: Windows 8 Upgrade // Touchpad Not Working Right - Acer Aspire V5 - 531

Thankyou very much - Works Great!

Posts: 3

Re: Windows 8 Upgrade // Touchpad Not Working Right - Acer Aspire V5 - 531

I have same problem with Aspire V5-571P. The touch pad is showing as simple mouse, no gestures working. Tried with re-installing the driver from acer support page but still no luck? do I need to do anything more?

Failed to "?eval" string with this error: ---begin-message--- Parsing error in ?eval-ed string in line 1, column 44954: Encountered "Hey", but was expecting one of: "," "}" "." "[" "(" "?" "!" "??" "+" "-" "*" "/" "%" "!=" "=" "==" ">=" ">" ".." ---end-message--- The failing expression: ==> community.settings.name.get("acer.videodata")?replace("\\","")?eval [in template "AcerVideoCarousel" at line 12, column 30] The failing instruction: ==> #assign allVideos = community.setting... [in template "AcerVideoCarousel" at line 12, column 9]

Welcome, Guest

Not A Member? Register
Member Highlight

IronFly set a new Acer Community record recently. He is the first member to author a whopping 500 Accepted Solutions. Impressive.

ACE Pathfinder

Did you know?

Acer Community is also available in the following languages:

We use cookies to ensure that we give you the best experience on our website. If you click below on the continue button, you agree to our use of cookies. Please click here if you would like to find more information about these cookies or change your cookie settings.