2013 Archives

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.

Topic

Regular Visitor
Posts: 3

Unable To Boot-Up After Windows Update for Bios - W500

Hi I think I have just accidentally bricked my W500i as I was updating my tablet via windows update. I remember ticking the Bios Update. After the restart it display nothing at all.
When try accesing boot menu via Power+Vol Up+Win Button+F2 it will cause to beep!
Tried all the solutions below but still no avail, how should I proceed guys? Really want to use back my tablet as its just less than a year or two old Smiley Sad
My warranty ended last 2 weeks, is there anything I can do?
Tried all the method of hard reset here:
http://www.hard-reset.com/acer-iconia-tab-w500-hard-reset.html
But none of those are working Smiley Sad

Acer Technician
Posts: 6,351

Re: Unable To Boot-Up After Windows Update for Bios - W500

We would suggest contacting technical support in your region for further assistance with this issue.
Acer Service and Support

Important Links: Global Support Pages | Knowledge Base Articles
Remember to mark posts that resolved your issue with Accept as Solution. You can even mark multiple posts in a single thread. This will make it easier for others to find the same information. Use the kudos-thumbs-up.png Give Kudos button to offer a thumbs-up for good post content and a pat on the back to the author.

Regular Visitor
Posts: 3

Re: Unable To Boot-Up After Windows Update for Bios - W500

Hi thanks for suggestion. I had just contacted acer and asked them to rectify the problem. They told me it was the mobo problem and had to replace the mobo for RM600 with 3 months warranty. Hope to see it soon ><

Service and Support Videos

Welcome, Guest

Not A Member? Register
Help
Language:

Did you know?

Acer Community is also available in the following languages:

We use cookies to ensure that we give you the best experience on our website. If you click below on the continue button, you agree to our use of cookies. Please click here if you would like to find more information about these cookies or change your cookie settings.