This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.


New User
Posts: 2

No wireless connection 5620z

I bought Extensa 5620z on 25th July 2013. Wireless internet will not work. Tried updating driver. Also reset to factory settings. Still no wifi and empowering technology now not working either. Any suggestions

Acer Technician
Posts: 6,349

Re: No wireless connection 5620z

That is a unit from 2008, not a newer model.


You're going to need to provide a lot more information about what you're seeing and what you've attempted to do troubleshooting the issue.  There are a lot of other posts about wireless connectivity and how to troubleshoot it.

Important Links: Global Support Pages | Knowledge Base Articles
Remember to mark posts that resolved your issue with Accept as Solution. You can even mark multiple posts in a single thread. This will make it easier for others to find the same information. Use the kudos-thumbs-up.png Give Kudos button to offer a thumbs-up for good post content and a pat on the back to the author.

New User
Posts: 2

Re: No wireless connection 5620z

I gave the unit back to Tesco and got an Inspiron instead. Much better model and €50 cheaper.Smiley Happy


Service and Support Videos

Welcome, Guest

Not A Member? Register
Member Highlight

Member RevoMaxx is quickly moving up the ranks of Acer Community.   He joined us in September and is already making a difference.   It's great to see new members like him make a difference only after a few months.
Thanks RevoMaxx!

Skilled Fixer

Did you know?

Acer Community is also available in the following languages:

We use cookies to ensure that we give you the best experience on our website. If you click below on the continue button, you agree to our use of cookies. Please click here if you would like to find more information about these cookies or change your cookie settings.