This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.

Topic

Visitor
ChaorruptedX
Posts: 2

Intel Turbo Boost Technology Not Working

Hello guys. This is my first post, sorry if I did any mistake. Okay, here goes nothing.

 

First, here's some information about my laptop that you might need to help me with this problem:-

- Laptop: Acer Aspire 4752G

- Operating System: Windows 7 Home Premium 64-bit (6.1, build 7601) Service Pack 1

- Processor: Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz (with Turbo Boost up to 3.0 GHz)

- Installed Memory (RAM): 2.00 GB (1.82 GB usable)

- System Type: 64-bit Operating System

 

Just like the title said. I'm having problem with the Intel Turbo Boost Technology, and I think it's not working.

How did I know it's not working? Well, I use the Intel Turbo Boost Technology Monitor 2.6 and when I run many programs, the maximum my CPU can reach is 2.4 GHz. It seems that the Intel Turbo Boost Technology is not working. Already tried reinstalling the Intel Turbo Boost Technology Monitor 2.6 and still showing the same result.

 

Last month, I still remember that when I open many programs, my CPU can go up more than 2.4 GHz. That means my Intel Turbo Boost Technology is activated/enabled. Someone said that I need to go to my BIOS to check whether my Intel Turbo Boost Technology is enabled or disabled, but once I arrived at my BIOS I can't find my Intel Turbo Boost Technology and I also don't have advanced tab (I don't know where's the Intel Turbo Boost Technology options located at).

 

Here's some of my BIOS information:-

- My BIOS Version/Date: Phoenix Technologies Ltd. V2.19, 19/3/2012

- SMBIOS Version: 2.6

* These information taken from msinfo32.exe

 

Do I really need to update my BIOS so I can see the Intel Turbo Boost Technology options and advanced tab in the BIOS? Well, I already go to their manufacture website, and I need to pay to update my BIOS!? Hmm, is there another way besides using money?

 

Before I create this topic, I search on the Internet about the Intel Turbo Boost Technology not working problems, and still not found any answers to solve this. Then I decide to create this topic. Hope someone can help me out with this problem.

 

I also make this topic in Intel Support too = http://communities.intel.com/thread/43714

 

Acer Technician
Acer-Tommy
Posts: 6,351

Re: Intel Turbo Boost Technology Not Working

You have the latest BIOS available for the system. 

There is no update that will "enable" an Intel Turbo Boost option in BIOS.

 

You state above that the function was working previously.

What has changed with the system recently?

 

Important Links: Global Support Pages | Knowledge Base Articles
Remember to mark posts that resolved your issue with Accept as Solution. You can even mark multiple posts in a single thread. This will make it easier for others to find the same information. Use the kudos-thumbs-up.png Give Kudos button to offer a thumbs-up for good post content and a pat on the back to the author.

Welcome, Guest

Not A Member?   Register
Help
Language:
Member Highlight

Long time Acer Community member and leader Padgett has reached a new milestone of 1500 posts helping and guiding others to solution. Please join me in congratulating Padgett on this accomplishment.

ACE Pioneer

Did you know?

Acer Community is also available in the following languages: