2013 Archives

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

See our Discussion Forums for more current content.

Topic

Frequent Visitor
Sunny
Posts: 1
Registered: ‎07-10-2013

Acer Aspire One netbook will not turn on/charge

I got my acer aspire one netbook in August 2009. It worked perfectly up untill the next June, when I accidentally left it on, shut, all night. The next day when I came to retrieve it, I found it completley unresponsive. No lights turn on, no matter what I press. It doesn't do anything when I charge it, and simply pressing the power button yields no results. I have tried charging it overnight, holding the power with the battery in and also with it out, leaving it with the battery out for a while, and charged it in different outlets. Simply nothing seems to work. I finally gave up on the prospect of having my computer back and it's been sitting in my room for a couple of years since then. It really does bother me that I paid so much money for something that didn't even last a year. Since it has been so long the warrantly has long worn off, and I cannot access tech support anymore. Does anyone have any idea of something that I could do to try to revive my netbook? Any ideas are welcome. Thank you.

Occasional Contributor
rajith
Posts: 50
Registered: ‎04-24-2013

Re: Acer Aspire One netbook will not turn on/charge

This can be a problem with the adapter, if possible, you can try with a different adapter and check whether the unit powers on or not. If that is the case, you have to purchase a replacement adapter or else, the unit needs service.
Member
Bravo696
Posts: 5
Registered: ‎08-20-2013

Re: Acer Aspire One netbook will not turn on/charge

Per: ACER and other web pages!

If the battery is completely discharged (or nearly so) the BIOS could be the problem.

They give you a download FLASH utility and instructions on how to do this.

 

That is supposed to be the answer, however it did not work on mine (I found this out after buying a new battery).

 

Flashing did not work and it is in a local shop along with another one from another customer.

The shop hasn't been able to flash the BIOS.  After the process the BIOS is still listed as the original version !

 

I have found statements that the BIOS reverts to the original factory setting if the BIOS battery goes bad.

My battery for the BIOS test good, so I will wait to see if the local shop can fix the two ASPIRE ONE units.

Did you know? Acer Community is also available in the following languages: