Examples: Monday, today, last week, Mar 26, 3/26/04

PREDATOR SENSE NOT SHOWING GPU

JRzdouffJRzdouff Posts: 4Member New User
Hey everyone,
My predator sense does not show the temperature of my gpu anymore even though the gpu is actually being used. It all happened after my laptop froze and that I had to force it to stop using the power button. By the way my laptop is a predator g3-572 with all up to date updates. 

Best Answers

  • sri369sri369 Posts: 1,756 Pathfinder
    Accepted Answer
    JRzdouff said:
    Hey everyone,
    My predator sense does not show the temperature of my gpu anymore even though the gpu is actually being used. It all happened after my laptop froze and that I had to force it to stop using the power button. By the way my laptop is a predator g3-572 with all up to date updates. 

    1. Disable "fast startup" under power settings.
    2. Restart.
    3. Wait for a few moments and start Predator Sense.
    If the GPU does not show, do not panic. Put the computer to sleep or hibernate, and wake it up. This will show it.

    I too have a G3-572, and face this issue at times after cold starts.
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    I am not an Acer employee.
    Your issue could get better coverage and more answers if posted in forums than in a message to me.

    ---------
    User benchmark: https://www.userbenchmark.com/UserRun/10977437


  • sri369sri369 Posts: 1,756 Pathfinder
    Accepted Answer
    Red-Sand said:
    sri369 said:
    1. Disable "fast startup" under power settings.
    2. Restart.
    3. Wait for a few moments and start Predator Sense.
    If the GPU does not show, do not panic. Put the computer to sleep or hibernate, and wake it up. This will show it.

    I too have a G3-572, and face this issue at times after cold starts.
    What does fast startup have to do with Predator Senses GPU monitoring?
    Fast startup does not allow clean cold startup of windows. That's why.
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    I am not an Acer employee.
    Your issue could get better coverage and more answers if posted in forums than in a message to me.

    ---------
    User benchmark: https://www.userbenchmark.com/UserRun/10977437


FAQ & Answers

  • Red-SandRed-Sand Posts: 1,797ACE Pathfinder
    As strange as it may sound... you can try force shutting down your laptop again and be sure to have any external monitor disconnected.
    - Hotel Hero
  • sri369sri369 Posts: 1,756ACE Pathfinder
    Accepted Answer
    JRzdouff said:
    Hey everyone,
    My predator sense does not show the temperature of my gpu anymore even though the gpu is actually being used. It all happened after my laptop froze and that I had to force it to stop using the power button. By the way my laptop is a predator g3-572 with all up to date updates. 

    1. Disable "fast startup" under power settings.
    2. Restart.
    3. Wait for a few moments and start Predator Sense.
    If the GPU does not show, do not panic. Put the computer to sleep or hibernate, and wake it up. This will show it.

    I too have a G3-572, and face this issue at times after cold starts.
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    I am not an Acer employee.
    Your issue could get better coverage and more answers if posted in forums than in a message to me.

    ---------
    User benchmark: https://www.userbenchmark.com/UserRun/10977437


  • Red-SandRed-Sand Posts: 1,797ACE Pathfinder
    sri369 said:
    JRzdouff said:
    Hey everyone,
    My predator sense does not show the temperature of my gpu anymore even though the gpu is actually being used. It all happened after my laptop froze and that I had to force it to stop using the power button. By the way my laptop is a predator g3-572 with all up to date updates. 

    1. Disable "fast startup" under power settings.
    2. Restart.
    3. Wait for a few moments and start Predator Sense.
    If the GPU does not show, do not panic. Put the computer to sleep or hibernate, and wake it up. This will show it.

    I too have a G3-572, and face this issue at times after cold starts.
    What does fast startup have to do with Predator Senses GPU monitoring?
    - Hotel Hero
  • JRzdouffJRzdouff Posts: 4Member New User
    Red-Sand said:
    As strange as it may sound... you can try force shutting down your laptop again and be sure to have any external monitor disconnected.
    Thank you very much for your answer although, it did not work. 
  • Red-SandRed-Sand Posts: 1,797ACE Pathfinder
    JRzdouff said:
    Red-Sand said:
    As strange as it may sound... you can try force shutting down your laptop again and be sure to have any external monitor disconnected.
    Thank you very much for your answer although, it did not work. 
    Bummer.
    I do have some other suggestions though.

    Try installing the Turbo Boost driver for your model from Acers driver download page.

    I've seen many issues solved by this and would be curious to see if it works for you too.

    Also if your using an on screen display or monitoring tool such as msi afterburner, try disabling the monitoring service and reboot.

    Perhaps its overriding Predator Senses priority.
    - Hotel Hero
  • JRzdouffJRzdouff Posts: 4Member New User
    Hey guys I have tried all of your techniques and it the gpu's temperature still does not show up. Thank you for all of your answers! 
  • Red-SandRed-Sand Posts: 1,797ACE Pathfinder
    Have you tried reinstalling Predator Sense or the GPU driver?
    - Hotel Hero
  • sri369sri369 Posts: 1,756ACE Pathfinder
    Accepted Answer
    Red-Sand said:
    sri369 said:
    1. Disable "fast startup" under power settings.
    2. Restart.
    3. Wait for a few moments and start Predator Sense.
    If the GPU does not show, do not panic. Put the computer to sleep or hibernate, and wake it up. This will show it.

    I too have a G3-572, and face this issue at times after cold starts.
    What does fast startup have to do with Predator Senses GPU monitoring?
    Fast startup does not allow clean cold startup of windows. That's why.
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    I am not an Acer employee.
    Your issue could get better coverage and more answers if posted in forums than in a message to me.

    ---------
    User benchmark: https://www.userbenchmark.com/UserRun/10977437


  • JRzdouffJRzdouff Posts: 4Member New User
    Red-Sand said:
    JRzdouff said:
    Red-Sand said:
    As strange as it may sound... you can try force shutting down your laptop again and be sure to have any external monitor disconnected.
    Thank you very much for your answer although, it did not work. 
    Bummer.
    I do have some other suggestions though.

    Try installing the Turbo Boost driver for your model from Acers driver download page.

    I've seen many issues solved by this and would be curious to see if it works for you too.

    Also if your using an on screen display or monitoring tool such as msi afterburner, try disabling the monitoring service and reboot.

    Perhaps its overriding Predator Senses priority.
    I actually just installed msi afterburner and it somehow fixed my problem with the predator sense. Thank you again everyone for all your answers! 
Sign In or Register to comment.

Who's Online158

BettyBoop06
BettyBoop06
egydiocoelho
egydiocoelho
GodOfDeath
GodOfDeath
MaClane
MaClane
MaxMadCal
MaxMadCal
sri369
sri369
Zelmel
Zelmel
+151 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.