Repair Acer R7-572-6423 - "Black Screen of Death"

alvaro777alvaro777 Member Posts: 9


Hi there!


I was experiencing issues with my R7 and I’d like to tell the community how I fixed mine just in case someone else is having the same issue (which as far as I saw online, it’s pretty common)



  • When trying to turn on the machine, my Acer Aspire R7-572 won’t post (acer logo won't show up when turning on).
  • Power led was on
  • I was able to hear the fan
  • Black screen…. Nothing appeared.
  • Sometimes (one out of 7 attempts), it eventually was able to post (you can tell because of the acer logo that appears in the screen) and get into the OS (this sometimes took 30min… sometimes 6 hours or even more). The thing is that even the OS was running, the machine wasn’t performing well (applications hanging/freezing a lot… when trying to open device manager, Windows Explorer used to hang).
  • There is a known issue with this machine BIOS: If you enter into your BIOS software and then you exit discarding changes, the machine won’t be able to boot. The fix is delivered in BIOS version 2.04. My machine had BIOS version 2.03. I didn’t try to get into the BIOS, so I guess this didn’t cause the problem on mine even though the symptoms were the same (Black Screen of Death). Since I was able to get into the OS, I tried to update the BIOS a couple of times; however, after restarting and waiting for it update the BIOS I eventually got the below error:  Img1.png
  • Guarantee expired a week ago plus I am in Costa Rica, which means, I need to send the machine to US to make the guarantee effective


After trying a lot other stuff (battery reset, tried with different hard drive, etc.) I finally decided to go through the BIOS recovery mode (a.k.a CRISIS recovery) to fix my corrupted BIOS as follows:

  1. Prepare an USB flash drive with the required files for recovery:
    • Copy the required files for the recovery procedure into your recently formatted USB flash drive. Find the files required for Acer R7-572 through this link. If you want to know how I got those files, read the “How did I get the required files?” section below. This might be helpful in case you want to do this for different ultrabook/laptop model
  2. Remove adapter (power cord) , mouse etc.
  3. Remove battery. The R7 has an internal battery which means you need to open it up (this may void your guarantee). This is easy to do, refer the first 1.5 minutes of this video to learn how to do it yourself:
  4. Attach USB flash drive that contains the files required from step 1 to the machine
  5. Hold down <Fn> + <Esc> keys
  6. Plug In the Ac Power adapter, wait about 3-5 secs
  7. Press the power button (at this point, you’ll hear the fan running at maximum speed. This means it is in CRISIS recovery mode)
  8. Now release the <Fn> + <Esc> buttons/keys.
  9. It may take about 2-3 minutes and the machine will power down itself....... give it some more time and it will turn on automatically. It’ll show the acer logo and get into the operating system (YAY! It’s working again!). Turn off the machine, so you can connect the battery back. From now on, it will turn on normally.


How did I get the required files?

Downloaded the latest BIOS/Firmware available from Acer for my Acer R7-572:


After extracting the files from the file, I got the below files:


Note: the name of the firmware/BIOS installer (V5MM2204) derives from the mainboard name (V5MM2) + Firmware version (2.04 =>204)… this will be important later on since you need to know what's your mainboard model so you can give a proper name to the .fd file required for flasing your BIOS.
According to many posts I found online, we can extract the files from V5MM2204.exe using 7Zip utility:


Now… where is the .fd file? If I open platform.ini file, we can see the name of the .fd file: “isflash.bin


However, it is not there… long story short, I did the following to find it:

  • Used Search Everything utility to monitor the existence of the file in my HDD and entered “isflash.bin” in the search box. The list was empty (it was not present in my HDD).
  • Then run V5MM2204.exe file and immediately the file existence was advertised by Search Everything tool:


  • Right clicked it and selected the option “Open path”. It was saved in temp folder (%temp%\7zS46B6.tmp\isflash.bin):


Well, according to platform.ini file, we now have the correct .fd file; but, it should have an specific name and extension so it is read while the machine is in CRISIS recovery mode. According to the info found in this post, the name of the .fd file used for this particular ultrabook model (R7-572) should be V5MM2x64.fd which is derived from the mainboard model (V5MM2) plus “x64.fd”.


Hope someone else finds this helpful.


FAQ & Answers

  • jamirom33jamirom33 Member Posts: 2

    Thank you  for the Post.  It gave me some hope, as I was a victim of the BIOS issue (exiting without saving) Black screen.


    However, I got all the way upto step 9 and unfortunately the laptop never shuts down to reboot.  Its still stuck in POST (Black screen).  Do you have any other ideas?

  • alvaro777alvaro777 Member Posts: 9


    the same (laptop never shuts down to reboot) happened to me because of an incorrect .fd file name.

    Such .fd file contains the ROM BIOS image and should have an specific name so it is properly read during the process (details are explained in my initial post). In my case, I required naming it as V5MM2x64.fd for my Acer R7-572-6423. Do you have the same machine model? If not, you'll need to get the files required for this procedure for your specific laptop model (refer to How did I get the required files? section from my initial post)


    Other than that, I'd suggest checking if your flash drive is properly formatted as fat32.

    Hope this helps!




  • padgettpadgett ACE Posts: 4,037 Pathfinder

    Accoring to my notes the R7 has a reset button pinhole on the bottom to clear everything. Have you tried that ?

  • jamirom33jamirom33 Member Posts: 2

    I checked the information under the hinge and my model is

         Aspire R7-572 Series

         Model No. V5MM1


    I double checked the markings on the mother board and they are V5MM2 LA-A021P


    Since the hinge information stated V5MM1, I tried renaming the the .FD file V5MM1x64.fd ; but I still ended up with the same result (stuck in post, Black Screen).


    In response to padgett - ACE Pioneer, I've tried the reset before and it does not seem to make any differnce.

  • alvaro777alvaro777 Member Posts: 9


    I see what you're saying... it seems we both have exact same model (I also noticed V5MM1 on mine), so the files that worked for me should work for you as well. Try downloading the files again (just in case something is corrupted) and make sure the drive is properly formatted


  • Martin34Martin34 Member Posts: 5


    with your perfect documentation I fixed my BIOS problem on my Acer Aspire E1-572.

    Thank you very much! Smiley Happy


  • alvaro777alvaro777 Member Posts: 9


    I am really glad this worked for you as well Martin Smiley Happy


  • darioismdarioism Member Posts: 1

    Thanks a ton, Alvaro!!! This worked on my Acer Aspire R7-572 and you saved me from having to go out and buy a new computer, not to mention the laborious data recovery process. Great fix!!! Thanks! 

  • alvaro777alvaro777 Member Posts: 9


    Hey buddy - genuinely happy to hear your machine is up and running again!!
    I appreciate you sharing the outcome.


    All the best,


  • killthezombiekillthezombie Member Posts: 2

    Hey Alvaro, thanks so much for such a great guide.


    One part i'm stuck on, is finding my .fd file from a bios downloaded from ACER. You talked about running a .exe then running "everything" to find the instance of isflash.bin. Like you I found my isflash.bin mentioned in platform.ini in the exact same way, but of course I'm using a second machine to locate this stuff. 


    Kind of a PC n00b question but when I run the main .exe that I have expanded to find such stuff inside, on a machine thats not an ACER, I dont run the risk of installing BIOS that is incompatible with the machine i'm using to set up the flash drive?


    Also, unfortunately, when I do actually run said application and run "everything" - It still didnt show any instance of "isflash.bin" - would you have any advice on finding the .fd?


    My machine is *i think* a little different from yours, its an Aspire E1 572. I found a forum where someone was posting links to the FD file removed but those links are all dead and nobody is replying to me!


    starting to lose hope :/





  • alvaro777alvaro777 Member Posts: 9


    Hi killthezombie,


    To bring you back some hope: one of the users who reported a satisfactory outcome, did it on an Aspire E1 572 (check previous comments).
    Sort answer for your first question, no.

    Long answer: after you double click the BIOS executable, it will extract the contents in a temporal directory and run the UI of the application that will actually perform the update (you'll need to do other stuff to actually apply it... so, it is more likely going to show an error or if it shows a window, just close it.)

    Not sure why you don't see isflash.bin file. Maybe your antivirus software thinks it is dangerous and deletes it... not sure though. I searched for your E1-572 model and found several updates. I took the latest one (2.17) and extracted the files for you. You may download them from here.

    Hope this helps!

  • killthezombiekillthezombie Member Posts: 2



    Thanks so much for this. I noticed you also included the correctly renamed .fd file and everything! thank you.



    Unfortunately, still, the machine still sits with a black screen. I am pretty certain I am in CRISIS mode with fans blowing full steam, but Ive noticed the tiny pinhole LED on my memory stick shows no activity. (well, one flash when it powers up)


    I might try formatting to FAT instead of FAT32, just in case, but i have a suspicion its a dead motherboard :/

  • Phil-3Phil-3 Member Posts: 1,182 Skilled Practitioner

    Hello everyone,

    While our members are generally eager to provide useful information, be advised that Acer does not validate third party external links for downloads and is not responsible for them.

    Acquiring files through such links is at the user’s own risk.



  • blub2016blub2016 Member Posts: 2

    hi there


    i've the same problem... great how-to... but i can't get the "isflash.bin" file... i've tried it on several pcs, i always got an error message "IHISI: Get support mode error in SMI! ..." and no temp files were created.

    can somebody send me the "isflash.bin" file??

    i need it for this notebook:




  • blub2016blub2016 Member Posts: 2

    i got it, i got it, i got it :-))))


    if somebody also has problems to get the isflash.bin temp file: in CMD run the exe-file with "/forceit". example: C:\Users\AlvaroIsAHero\V5MM2204.exe /forceit

    go to your temp folder, and the file(s) will be there...


    i was too lazy to remove the battery... it worked for me while i was penetrating the battery reset hole on bottom with a paperclip :-)))

    thank you alvaro!




  • alvaro777alvaro777 Member Posts: 9


    Awesome blub! those tips will be helpful to others for sure. I really liked the paperclip idea Smiley Happy


  • jordypoejordypoe Member Posts: 5


    I have an acer E5-573g my power cable busted and my computer powered off mid use and won't start up again (black screen no acer logo) I tried running the .exe and going to the temp folder to find the ZRT.fd (my motherboard model is ZRT) renamed it "ZRTx64.fd" held fn+esc nothing. Do you guys use a boot loader or just a fresh format?
  • BradSBradS Member Posts: 1 New User
    I realize this is an old thread but I just came across it because I had the same issue after many hours of frustration.  I found that if you remove the power and battery, unplug the RAM modules and put them back in the laptop will boot.  I did this for way more time than I'd like to admit trying to find a solution.  

    Point is, since you can get the computer to boot your don't need to go through the Panic method.  I tried to use the latest bios update first from the Acer website and it failed saying "name mismatch".  I used the 2.04 version downloaded from the link above and joy!  Hope this helps someone else.
  • RedStickJimRedStickJim Member Posts: 1 New User
    Not sure if I understand the process above.  My R7 battery was not holding charge so I ordered a new one, same model number etal, followed instructions found in youtube video (old battery was really puffed up) seemed simple enough but when I turned on, amber power came on and blue light came on and went off in a few seconds.  Did the pinhole reset and waited at least 4 minutes as one video suggested and still no joy.  Did this process "blow" the bios? Since the  unit won't power up will the above process still work?  Really love this unit and hope to recover.
Sign In or Register to comment.

Who's Online1K

+1K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer

Drivers &


Get Product Information
( only)

Acer Support