V5 573g memory upgrade failure

ed091mafed091maf Member Posts: 3

Installed additional 4gb memory of Kingston brand, specifically http://www.kingston.com/datasheets/KVR16S11S8_4.pdf

On initial BIOS 2.21 computer didn't start at all. Upgraded BIOS to 2.24 and the computer starts normally however additional installed memory is not recognized. The slot on the motherboard shows number 1.5V, so i suppose that my memory should be compatible as it is for 1.5V. Any ideas what is wrong? Wait for BIOS update?

FAQ & Answers

  • excelonexcelon Member Posts: 2

    I have a V5-573P-6896 and ran into the same problem. Only with one difference.. after buying an 8GB of DDR3L 1.35V the system recognized the memory fine, after restarting the computer it would go down to 4GB. However whenever I hit the reset pin on the bottom of computer it would recognize the extra ram for a total of 12GB. However, when I shut down/restart it would go back to recognizing 4GB???

     

    I don't know what's up with Acer. Definately a problem with the BIOS software because it is recognizing it sometimes. 

  • excelonexcelon Member Posts: 2

    Today I tried Patriots Viper 4GB DDR PC3-12800 1600MHZ which is 1.35v and CL9 and had the SAME ISSUE. Acer please update BIOS. 

  • sirhimsirhim Member Posts: 3

    ed091maf, even though it says 1.5v on the bracket, it is wrong. This laptop uses DDR3L. Get some 1.35v memory.

     

    excelon, your problem seems a bit more tricky. I would imagine both of those should work. I've used both g.skill cas9 and crucial cas 11 ram at 1.35v and they work. 

     

    My problem is that it doesn't work at 1600Mhz. I thought it was because my cas was 9, so I puchased some crucial cas11 memory (The soldered on ram on the 573P is 1600Mhz 11-11-11-28). It works at first, but kind of like you, when I power it off and on it turns back to 1333. The only way I can get it back to 1600 is by pushing the battery disconnect button on the bottom of the laptop. I guess after powering down the first time the bios implements it's safeguards :/

     

    I really wish we had some kind of feedback from Acer but it doesn't seem like they pay attention to these forums... 

  • SomeoneSomeone Member Posts: 7

    Hello! Are these issues present with BIOS 2.28? I would like to upgrade RAM and now I'm not sure any more.

  • SomeoneSomeone Member Posts: 7

    I bought Kingston KVR16LS11/4, everything works great for now! BIOS version is 2.28

     

    For those who are looking for it, here are the specifications needed for V5-573G:

    • DDR3 (sometimes DDR3L, where L means low voltage: 1.35V)
    • 1600MHz
    • PC3L-12800
    • 1.35V (very important, higher will not work! Even though it says 1.5V on the motherboard.)
    • SO-DIMM (offcourse)

     

This discussion has been closed.

Who's Online1.1K

Acer-Samuel
Acer-Samuel
Beadz
Beadz
brummyfan2
brummyfan2
Cyriix
Cyriix
egydiocoelho
egydiocoelho
JackE
JackE
jonnyreading
jonnyreading
Jose_Manuel
Jose_Manuel
LinkSlotGacor
LinkSlotGacor
milsabords
milsabords
molydoly
molydoly
pedromonval
pedromonval
Petre01
Petre01
RenanVilela
RenanVilela
rwm
rwm
thalmanl
thalmanl
YLFSKRAPS
YLFSKRAPS
Thirskcounselling22
Thirskcounselling22
ammebo
ammebo
+1.1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers