Aspire TC-780 USB Boot

I have been trying to boot to debian's network installer on a thumb drive, but it always gives the message "Reboot and Select proper Boot Device". I have tried switching between UEFI and legacy boot, turning on/off CSM, turning on/off TPM, yet I always get that message. I finally tried factory resetting the settings and turning off secure boot, and now a different thumb drive with ubuntu on it that worked before now doesn't work either. I think I remember having this issue 1 or 2 years ago, but was able to fix it. Am I missing a setting?

Best Answer

  • ldare373ldare373 Member Posts: 3 New User
    Accepted Answer
    Sorry for the late update, but resetting the settings and entering the same settings back in somehow fixed it.

FAQ & Answers

  • billseybillsey ACE Posts: 16,048 Trailblazer
    You should be in UEFI mode, with the F12 boot menu enabled and secure boot disabled. The flash drive you will be booting from should have a UEFI OS on it and be in GPT mode. When you first start to boot hit the F12 key and choose the USB stick as your boot source and it should go ahead and work.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • ldare373ldare373 Member Posts: 3 New User
    billsey said:
    You should be in UEFI mode, with the F12 boot menu enabled and secure boot disabled. The flash drive you will be booting from should have a UEFI OS on it and be in GPT mode. When you first start to boot hit the F12 key and choose the USB stick as your boot source and it should go ahead and work.
    That is what it was set to at the beginning, and it wasn't showing up. The thumb drive also worked on a laptop with UEFI on and secure boot off. 
  • tttttttttt Member Posts: 560 Seasoned Specialist
    @Idare373
    Have you done a clean installation of Ubuntu from image? The thumb drive worked with another laptop doesn't mean it will work with the hardware with this one. Even a Knoppix will not work with every PC.
  • StevenGenStevenGen Member Posts: 1,567 Community Aficionado
    ldare373 said:
    I have been trying to boot to debian's network installer on a thumb drive, but it always gives the message "Reboot and Select proper Boot Device". I have tried switching between UEFI and legacy boot, turning on/off CSM, turning on/off TPM, yet I always get that message. I finally tried factory resetting the settings and turning off secure boot, and now a different thumb drive with ubuntu on it that worked before now doesn't work either. I think I remember having this issue 1 or 2 years ago, but was able to fix it. Am I missing a setting?
    Follow these easier steps "How to Install Debian via the Internet" here: How to Install Debian via the Internet - Make Tech Easier you must have done something wrong. 
  • ldare373ldare373 Member Posts: 3 New User
    Accepted Answer
    Sorry for the late update, but resetting the settings and entering the same settings back in somehow fixed it.
Sign In or Register to comment.

Who's Online728

Angry_Beaver
Angry_Beaver
brummyfan2
brummyfan2
Javic4
Javic4
majestyNL
majestyNL
Reiyy
Reiyy
sameermundekar
sameermundekar
seliobento
seliobento
xapim
xapim
Ziyaaaa
Ziyaaaa
+719 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos