"No bootable device" Problem (Modell: Acer Swift SF314-55-54UE)

Optionen
Florian4444
Florian4444 Member Beiträge: 20 Networker
bearbeitet Dezember 2023 in Swift & Spin

Hallo,

bei meinem Laptop hat sich das "No bootable device" Problem ergeben. Ich habe schon ein paar Dinge ausprobiert, aber das Problem noch nicht lösen können.

Folgendes steht mir bislang für die Problemlösung zur Verfügung:
- Der Acer Swift SF314-55-54UE
- zweiter Laptop
- externe SSD
- Knoppix ISO (mit Rufus auf die externe SSD gebracht)
- Windows 10 ISO (über das Media Creation Tool auf die externe SSD gebracht)
- externe HDDs für Sicherungen


Was ich noch besorgen könnte, aber noch nicht habe:
- neue SSD zum Einbau in den Laptop

Was ich noch nicht ausprobiert habe:
- Laptop aufschrauben, Verkabelung überprüfen, SSD austauschen etc

Was passiert ist:
Der Laptop lief, während ich etwa eine Stunde weg war. Als ich zurück kam, leuchtete die "No bootable device"-Meldung. Weitere Neustart-Versuche haben ebenfalls immer zu der Meldung geführt. Entweder ist der Laptop abgestürzt, während ich weg war. Oder Windows hat in der Zeit ein Update durchgeführt.

Was möglich war:
Ich konnte nur noch per F2/F12 ins Bios. Die "Erweiterten Startoptionen" (F8) ließen sich nicht öffnen.

Zum Bios:
Die Seiten "Information" und "Boot" habe ich als Fotos eingefügt.



- "Information" sieht für mich okay aus. Die SSD wird unter "HDD Model Name" und "HDD Serial Number" angezeigt.
- Was ich schon ausprobiert habe, ist per F9 die Standardeinstellungen wiederherzustellen (ich weiß nicht, ob vorher etwas verändert war…ich glaube aber nicht). Das hat das Problem nicht gelöst.
- Auf der Seite "Boot" ist "Boot Mode: [UEFI]" grau, sodass es sich nicht verändern lässt. Unter "Boot priority order:" wird nichts angezeigt. Es sei denn, ich hänge meine Externe Festplatte mit Knoppix oder Windows 10 per USB an. Dann erscheint die dort, bzw. von der wird gebootet (siehe nächste Punkte). Aber von der Internen SSD kann nicht gebootet werden.

Was ich dann probiert habe:
1) Per Knoppix (externe SSD) schauen, ob ich auf die interne SSD zugreifen kann (Daten sichern etc). Das hat funktioniert. Ich habe diverse Ordner von der internen SSD auf eine weitere externe HDD-Festplatte sichern können. Die Ordner lagen auf dem Laufwerk "C", auf dem auch Windows installiert ist.
→ Die Windows-Ordner habe ich nicht im Detail überprüft. Könnte ich noch machen, aber ich weiß bislang nicht genau, wonach ich konkret suchen müsste.
→ Bislang habe ich nur einige Daten-Ordner gesichert. Programm-Ordner oder eventuell das komplette System (durch Klonen der Festplatte) habe ich noch nicht gesichert. Eventuell würde ich das noch machen, bevor die Festplatte formatiert wird, bzw. bevor die Daten verloren gehen. Das würde die Einrichtung des neuen Systems (eventuell auf einer neuen SSD) erleichtern. Aber alle wichtigen Daten habe ich bereits gesichert. Ein bisschen Experimentieren ist ab hier erlaubt.

2) Per Windows 10 (externe SSD) bin ich in die "Erweiterte Optionen"-Funktion gekommen.
→ "Updates deinstallieren" funktioniert nicht (Screenshot mit der genauen Formulierung kann ich noch erstellen, falls nötig)
→ "Starthilfe" funktioniert nicht (Screenshot mit der genauen Formulierung kann ich noch erstellen, falls nötig)

→ "System wiederherstellen" zeigt tatsächlich 3 Wiederherstellungspunkte an. Der neueste Punkt ist tatsächlich erst ein paar Tage alt. Auch das funktioniert aber nicht (alle 3 Wiederherstellungspunkte ausprobiert). Das Foto mit dem genauen Text habe ich eingefügt.



Laut Text soll möglicherweise das Laufwerk "C" beschädigt sein. Empfohlen wird eine Überprüfung des Laufwerks mit Chkdsk. Das habe ich später gemacht, siehe unten.

3) Was ich dann versucht habe, ist: Mit "bcdboot" den Bootmanager (für GPT) reparieren (siehe Foto).



- Mit Diskpart habe ich zur internen SSD navigiert und mit "list par" die Partitionen aufgelistet.
- Auf die System-Partition habe ich dann "bcdboot" angewendet. "Die Startdateien wurden erfolgreich erstellt" erscheint.
- Auch das hat das Problem nicht behoben.

4) Dann habe ich versucht, mit "Chkdsk" die interne Festplatte zu überprüfen. (Weiterhin in der Eingabeaufforderung der Erweiterte Optionen Funktion von Windows, die ich über die per USB angeschlossene externe SSD mit Windows 10 aufrufen kann.)

- Das Foto der "Chkdsk"-Überprüfung von Laufwerk "C" habe ich eingefügt. Bei der Überprüfung von "C" ist ein Fehler aufgetreten, 2 Zeilen "Unbekannter Fehler" werden angezeigt. 1. Zeile: "Unbekannter Fehler (6e74667363686b2e 11e1)". 2. Zeile: "Unbekannter Fehler (6e74667363686b2e 17b4)"



- Vorher hatte ich testweise erst einmal das System-Laufwerk überprüft. Da lief die Überprüfung ohne Fehler durch. Die Laufwerke "Reserviert" und "Wiederherstellung" habe ich noch nicht ausprobiert. Könnte ich noch machen, aber offenbar liegt der entscheidende Fehler bei Laufwerk "C" vor.

5) Ich habe danach noch einmal Knoppix gebootet, um auf die interne SSD noch einmal zuzugreifen. Das funktioniert weiterhin. Ich konnte testweise auf alle Dateien von Laufwerk "C" zugreifen, die ich ausprobiert habe. Ich bin also nach wie vor unsicher, ob die interne SSD defekt ist, oder ob ein anderes Problem vorliegt. Knoppix fragt beim Zugriff auf die interne SSD (Mount NTFS), ob die "Hibernate"-Datei entfernt werden soll (Foto eingefügt).



Das hatte ich zunächst nicht gemacht, weil mir der "nur lesen"-Modus reichte, um meine Daten zu kopieren und damit zu sichern. Jetzt habe ich doch einmal ausprobiert, ob Knoppix die "Hibernate"-Datei entfernen kann, und ob das irgendetwas bringt. Daraufhin zeigte mir Knoppix aber nur die "Error mounting"-Fehlermeldung an (Foto eingefügt).



Im "nur lesen"-Modus auf die interne SSD zugreifen funktioniert aber weiterhin. Ich weiß nicht, ob die "Hibernate"-Fehlermeldung etwas zu bedeuten hat, aber ich dachte mir, ich schreibe das hier mal dazu, falls sich daraus doch irgendetwas schließen lässt, was bei der Problemidentifizierung hilft.

Habt ihr Ideen, was genau das Problem sein könnte?

Wenn möglich, wären das meine Prioritäten (absteigend):
1) Das Problem so lösen, ohne dass ich eine neue SSD benötige und das System und alles an Programmen/Einstellungen/etc neu installieren muss.
→ Dafür habe ich die Dinge ausprobiert, die mir bekannt sind.
→ Es wäre super, wenn es noch weitere Ideen gibt, die ich ausprobieren kann.
2) Eine neue SSD einbauen, aber das System von der alten SSD übernehmen, indem ich die komplette Festplatte klone.

→ Für den Ausbau/Einbau der SSD brauche ich eventuell Hilfe. Und Stand jetzt weiß ich auch nicht, wie ich die komplette interne SSD klonen kann. Aber falls es funktioniert, wäre der Aufwand okay.
3) Die alte SSD weiter nutzen, aber die SSD einmal formatieren und das System neu installieren.
→ Da bin ich mir nicht sicher, ob ich das so hinbekomme bzw. alles dafür Nötige habe. Bislang habe ich - wenn überhaupt - die Wiederherstellungsoptionen genutzt, die das vorinstallierte System bot (also Zurücksetzen auf Werkseinstellungen).
4) Neue SSD, System neu installieren.
5) Neuer Laptop. Wahrscheinlich nicht nötig, wenn abseits der SSD alles in Ordnung ist. Wäre rein finanziell kein Drama, aber da der Laptop gut lief und alles so eingerichtet war, wie es mir gefiel, würde ich mir gerne den Stress ersparen alles wieder neu installieren, neu einstellen, usw. zu müssen.
——————————————————————-
Folgende Fragen hätte ich:
a) Wie gesagt die Frage, ob ihr noch irgendwelche Ideen habt, wo das Problem liegen kann und was ich ausprobieren kann, bevor ich den Austausch der SSD versuche.
b) Ergänzende Frage: Wisst ihr, wie ich - in diesem Zustand, ohne dass das "Bootable device" erkannt wird - herausfinden kann, ob es überhaupt noch Windows 10 ist, das vor dem Absturz installiert war? (bzw. wie ich herausfinden kann, wie der aktuelle Update-Stand ist, oder ob ein Update das Neustarten des Laptops und dann das "No bootable device"-Problem verursacht hat) Ich bin mir nämlich unsicher, ob ich schon auf Windows 11 geupdated hatte, und ich weiß nicht, wie ich das herausfinden kann. Für das Problem hier sollte es aber, denke ich, keinen Unterschied machen, oder?

c) Eventuell benötige ich Hilfe beim Ausbauen/Einbauen der SSD. Falls ich das machen muss, würde ich es aber erst einmal selbst ausprobieren (mit Online-Recherche/Video-Anleitung). Falls sich dann Fragen stellen, würde ich die hier noch stellen.
d) Für das Klonen der kompletten SSD auf eine neue SSD (falls es das Richtige wäre, um das Problem am einfachsten zu beheben) ergeben sich eventuell auch noch Fragen. Jetzt hätte ich erst einmal die Frage, ob ich beim Klonen der (womöglich defekten) internen SSD das "No bootable device"-Problem mit kopiere.

Also, was soll ich machen? Vielen Dank für Hilfe! :)

[Bearbeitet, um sensible Informationen zu entfernen] Sarah-Acer

Beste Antworten

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    bearbeitet Dezember 2023 Antwort ✓
    Optionen

    Hi ,

    schau mal bitte hier in den Thread, da ist das meiste, das bei der Installation wichtig ist, beschrieben (Datum anklicken zum Öffnen):

    Nachdem du mittels des F12 Bootmenüs vom Stick gebootet hast und "Benutzerdefinierte Installation" ausgewählt hast, löschst du hier im Fenster alle alten Partitionen auf dem Systemlaufwerk (einschließlich der EFI Partition).

    Wenn diese gelöscht sind, sollte auf der System SSD nur noch "nicht zugeordneter Speicher" zu sehen sein.

    Ab diesem Punkt kannst du so vorgehen, wie im verlinkten Thread beschrieben.

    Gruß

    Jochen

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    Antwort ✓
    Optionen

    Tut mir leid, keine Ahnung, was da schiefläuft.

    Ich hab bestimmt schon 35- 40 cleane Neuinstallationen von Windows durchgeführt, aber daß die Partitionen sich nicht löschen lassen, ist mir noch nicht passiert.

    Wenn du mit einer neuen SSD installierst: Der Windows Lizenzschlüssel ist auf dem Mainboard hinterlegt und wird automatisch ausgelesen.

    Falls wider Erwarten doch eine Lizenzschlüsselabfrage käme, wähle "ich habe keinen Lizenzschlüssel". Die Aktivierung des Schlüssels erfolgt dann, sobald du eine Internetverbindung eingerichtet hast, online über die Microsoft Server.

    Gruß

    Jochen

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

Antworten

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    bearbeitet Dezember 2023
    Optionen

    Hallo Florian4444,

    versuch mal folgendes:

    Du hast ja in Diskpart der EFI Systempartition (rot umrandet) deswegen einen Laufwerksbuchstaben (z) gegeben, damit du auf dieser Partition eine Reparatur vornehmen kannst.

    Dein Foto: Partition 1 (EFI Systempartition) erhält den Buchstaben "z":

    "C" ist Partition 3.

    Schau mal in folgende Anleitung, bei der, anstatt "z", der Buchstabe "V" genommen wurde. Ob "z" oder "V" ist egal. Bei deinem Reparaturversuch fehlt, daß du jetzt zum Laufwerk "z" (oder V) wechselst:

    https://www.heise.de/tipps-tricks/Windows-10-Bootmanager-reparieren-so-geht-s-4268553.html

    Gib also nach "Diskpart - exit" folgenden Befehl ein, damit du auf die EFI Partition (bei dir "z" genannt) zugreifen kannst. "cd" bedeutet "change directory", und so wechselst du zu Laufwerk "z".

    Bei mir wird natürlich kein Laufwerk "z" gefunden, weil ich der EFI Partition nicht diesen Buchstaben zugeteilt habe.

    Du müsstest aber jetzt Zugriff auf "z" haben und dort den Befehl bootrec /FixBoot eingeben können.

    Erst danach gibst du den Befehl "bcdboot c: \Windows /l usw. ein

    Wenn dieser Tipp nichts nützt, kann ich dir nur empfehlen, Windows (10 oder 11) mit Hilfe des Media Creation Tools clean neu zu installieren, und dabei die System SSD komplett zu löschen.

    Wenn der Fehler in dieser EFI Systempartition enthalten ist, dann nützt ein Klonen des Laufwerks überhaupt nichts, denn dann klonst du den Fehler tatsächlich mit.

    Ich hab leider heute keine Zeit mehr; werde erst morgen im Lauf des tages wieder in die Community reinschauen.

    Gruß

    Jochen

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    Danke für die Hilfe!

    Stimmt, das Navigieren zu "z" hatte ich vergessen. Aber ist das wirklich notwendig? Der Befehl "bcdboot c:\windows /l de-de /s z: /f UEFI" müsste doch eigentlich das Nötige enthalten. "C" ist ja das "Acer"-Laufwerk mit der Windows-Installation (wenn ich es falsch eintippe, erhalte ich "Fehler beim Kopieren der Startdateien", ansonsten eben "Die Startdateien wurden erfolgreich erstellt."). Das von mir zugewiesene "Z" bezieht sich auf das "System"-Laufwerk (Partition "ESP").

    Die Anleitung mit diesem Befehl hatte ich von:
    "Windows 10 EFI-Partition reparieren/wiederherstellen" (von "german-syslinux-blog")

    Das Zitat von dort lautet:
    "Immer noch in der Eingabeaufforderung gebt Ihr nun folgendes ein:

    Codezeile(n)

    1

    bcdboot c:\windows /l de-de /s z: /f UEFI


    Dadurch werden auf der EFI-Partition die Standardordner \EFI\Microsoft\Boot erstellt und auch alle nötigen Startumgebungsdateien kopiert.Mit C:\Windows ist der Pfad zu der Windowsinstallation gemeint. de-de sind die Sprach-Codes für die deutsche Sprache. “z:” ist hier unsere EFI-Partition, der wir zuvor einen Laufwerksbuchstaben gegeben hatten. Als Firmwaretyp geben wir UEFI an."

    Mein neuer Versuch nach "Heise"-Anleitung sieht so aus:


    Die Heise-Anleitung hatte ich auch schon aufgerufen, bevor ich die von "german-syslinux-blog" gefunden habe, aber ich glaube, die von "Heise" ist etwas fehlerhaft, oder? In jedem Fall funktioniert "bootrec /fixboot" bei mir nicht (Zugriff verweigert). Wenn ich meine Google-Recherche richtig interpretiere, funktionierte der "bootrec /fixboot"-Befehl bei MBR, aber nicht bei GPT. Sicher bin ich mir aber nicht.

    Allgemein muss ich dazusagen, dass ich mir vieles anlese, aber komplett mit Halbwissen unterwegs bin.
    —————————————————————-
    Ich habe noch einen weiteren Versuch gemacht, mit einer etwas anderen Anleitung (Artikel "How to Fix a No Bootable Device Error on Windows 10" von der Seite "helpdeskgeek"). Die Erläuterung finde ich gut.

    Dann erscheint allerdings das hier:

    "BFSVC Warning: System BCD store is corrupt."

    Und tatsächlich funktioniert weiterhin nichts.
    —————————————————————-
    Ich vermute mal, dass ich dann tatsächlich Windows neu installieren sollte. Ich werde morgen noch mal weiterschauen, und dann alle weiteren eventuell hilfreichen Dateien und Programm-Ordner schon mal über "Knoppix" sichern. Falls ich dann Windows 10 neu installieren muss, ergeben sich eventuell weitere Probleme und Fragen.

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    Also, ich bringe jetzt wieder Windows 10 mit dem Media Creation Tool auf die USB-SSD, um dann damit zu installieren.

    Die "Acer"-Partition ("C") sollte damit dann vollständig überschrieben werden, wenn ich Windows dort installiere, oder? Wie sieht das bei den anderen Partitionen aus? Muss ich daran etwas ändern, speziell an der "System"/ESP"-Partition?

    Die "Recovery"/"Wiederherstellung"-Partition und die "Reserviert"/"ESD-USB"-Partition ("D") sollte ich auf jeden Fall so lassen, oder?

    Wie wird denn die "System"/"ESP"-Partition wieder so, dass von dort gebootet wird? Muss ich dafür irgendetwas manuell machen, oder erledigt das Windows dann automatisch, wenn ich es auf die "Acer"/"C"-Partition installiere?

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    bearbeitet Dezember 2023 Antwort ✓
    Optionen

    Hi ,

    schau mal bitte hier in den Thread, da ist das meiste, das bei der Installation wichtig ist, beschrieben (Datum anklicken zum Öffnen):

    Nachdem du mittels des F12 Bootmenüs vom Stick gebootet hast und "Benutzerdefinierte Installation" ausgewählt hast, löschst du hier im Fenster alle alten Partitionen auf dem Systemlaufwerk (einschließlich der EFI Partition).

    Wenn diese gelöscht sind, sollte auf der System SSD nur noch "nicht zugeordneter Speicher" zu sehen sein.

    Ab diesem Punkt kannst du so vorgehen, wie im verlinkten Thread beschrieben.

    Gruß

    Jochen

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    bearbeitet Dezember 2023
    Optionen

    Ergänzung: Falls das nicht klar wurde: Nach dem kompletten Löschen des Laufwerks erstellt Windows automatisch alle notwendigen Partitionen neu. Achte unbedingt darauf, daß diese 3 Partitionen gelöscht werden:

    Das hier zu sehende Laufwerk 1 ist der Installationsstick, der aber nur angezeigt wird, wenn der Stick 64 GB hat.

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    Das Löschen funktioniert bislang nicht. Ich hatte mich vorhin schon mal selbst herangetastet und versucht die "Acer"/"C"-Partition #3 zu formatieren/löschen (erst formatieren probiert, dann löschen). Danach dann auch mit der "System"-Partition #1 versucht (#2 und #4 habe ich noch nicht versucht). Über "Diskpart" habe ich auch schon versucht die beiden Partitionen zu löschen. Es scheint sich nichts geändert zu haben.

    Die Darstellung sieht immer noch so aus. Trotz mehrerer Versuche die beiden Partitionen zu löschen.

    Was lässt sich daraus schließen? Über Knoppix konnte ich auf die "Acer"/"C"-Partition zugreifen (nur Lese-Modus) und alle Ordner auf eine externe HDD sichern. Aber scheinbar kann ich auf der SSD-Festplatte nichts mehr verändern, auch nicht formatieren/löschen.

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    Könnte ich die SSD austauschen (falls es an ihr liegt) und analog zu Deiner Erläuterung auch auf der neuen SSD frisch installieren? Wird der Windows Product Key dann noch automatisch erkannt, oder muss ich den mir jetzt irgendwie speichern/auslesen?

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    (Ergänzung: In DiskPart stand bei beiden Partitionen sinngemäß, dass die Partition erfolgreich gelöscht wurde. Dann habe ich das Windows Installation Setup wieder aufgerufen, und die Darstellung mit den Partitionen, ohne freien Speicherplatz ist immer noch identisch. Im Setup selbst bekomme ich bei "System"-Partition #1 die obige Fehlermeldung, bei "Acer"-Partition #3 tut sich gar nichts.)

    Ich tendiere also zum Kauf einer neuen SSD. "Samsung 970 EVO Plus", wenn nichts dagegen spricht (ich hatte gestern schon mal etwas recherchiert, ob die zum Acer Swift kompatibel sein könnte).

    Aber ich bin mir eben noch unsicher, ob ich da dann auch frisch installieren kann, bzw. ob der Windows Produkt Key erkannt wird, wenn die Festplatte ausgetauscht wurde.

  • Kno63
    Kno63 ACE Beiträge: 15,396 Trailblazer
    Antwort ✓
    Optionen

    Tut mir leid, keine Ahnung, was da schiefläuft.

    Ich hab bestimmt schon 35- 40 cleane Neuinstallationen von Windows durchgeführt, aber daß die Partitionen sich nicht löschen lassen, ist mir noch nicht passiert.

    Wenn du mit einer neuen SSD installierst: Der Windows Lizenzschlüssel ist auf dem Mainboard hinterlegt und wird automatisch ausgelesen.

    Falls wider Erwarten doch eine Lizenzschlüsselabfrage käme, wähle "ich habe keinen Lizenzschlüssel". Die Aktivierung des Schlüssels erfolgt dann, sobald du eine Internetverbindung eingerichtet hast, online über die Microsoft Server.

    Gruß

    Jochen

    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Florian4444
    Florian4444 Member Beiträge: 20 Networker
    Optionen

    Super! Danke! :) Dann warte ich mal auf meine neue SSD und mache es so.