Acer Swift 3 314 57 Linux Ubuntu

Optionen
Oldtjikko
Oldtjikko Member Beiträge: 2 New User
bearbeitet April 2023 in 2019 Archiv
Hi,

ich hatte Ubuntu 19.10 mit auslieferungs Kernel installiert und fast alles lief auch ok bis auf ACPI Error bzw. Hibernate und er hat mir immer einen Systemfehler ausgeworfen den ich aber nicht identifizieren konnte. Firmware 1.07 war installiert und ich  konnte im Bios  zwischen ACHI / Optane wählen.
Mein Problem ist jetzt. das ich in der Hoffnung die Fehler zu beheben, auf Bios 1.09 geupdatet habe und Ubuntu meine Linux Partition nicht mehr erkennt. Mein erster Gedanke war an dieser Optane Einstellung im Bios eine Änderung vorzunehmen, aber die ist jetzt nicht mehr da. Linux gibt mir diesen Hinweis im Bootlog das ich diese Einstellung im Bios überprüfen und änder soll damit die Partition wieder erkannt wird.
Meine Idee ist jetzt das Bios auf 1.07 zurückzuflashen und die Einstellung zu ändern, aber das Flashtool weigert sich zurückzuflashen.
Frage 1) Kann ich meine Bios Version faken, also irgendwo im Speicher den Wert ändern damit das Tool arbeitet?
Frage 2) Gibts eine andere Möglichkeit Bios Einstellungen zu machen, denn mein Windows läuft fehlerfrei.

Ich habe auch versucht per Freedos das Flashtool zu starten aber der Rechner weigert sich meine USB Sticks mit Freedos als Bootoption zu akzeptieren.

Vielleicht kann ja einer von euch Helfen damit ich wenigstens meine Platte wieder erkannt bekomme. Mit den ACPI Fehlern werde ich dann wohl für eine Weile leben müssen.

Gruß

Es ist Acers gutes Recht Linux zu ignorieren, aber dann sollen sie das auch kommunizieren. Ein paar kleine Fehler hier und da sind verzeihlich aber das OS komplett auszusperren indem man extra eine Bios Option entfernt ist schon sehr merkwürdig.



Beste Antwort

  • Kno63
    Kno63 ACE Beiträge: 15,520 Trailblazer
    bearbeitet Dezember 2019 Antwort ✓
    Optionen
    teste mal, ob du mit diesem Shortcut im BIOS wieder zwischen Optane und AHCI wählen kannst, und ob unter AHCI das Problem nicht mehr auftritt. Was derjenige, der mir die Information zukommen ließ, von diesem Feature hält, habe ich weggelassen. Ich finde, daß man einen Preis für eines der "bescheuertsten Features des Jahres" verleihen könnte:


    Übersetzt: Der (einstellbare) SATA Mode wird erst sichtbar, wenn der User "Strg + S " unter dem Reiter "Main" drückt.
    Gruß
    Jochen
    Edit: Daß die Option nicht mehr offen zur Verfügung steht, betrifft die Windows User ähnlich stark, wie die Linux Nutzer. Hat nichts mit "Linux ignorieren" zu tun. Es gibt einige Windows User, die hier in der Community berichten, daß neu installierte NVMe SSDs im Optane Modus nicht erkannt  werden, und über andere, ähnliche Probleme.
    Man sollte aktuell auch als Windows User bei einem Clean Install von Windows vorher den AHCI Modus aktivieren, um potentiellen Problemen aus dem Weg zu gehen.
    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

Antworten

  • Kno63
    Kno63 ACE Beiträge: 15,520 Trailblazer
    bearbeitet Dezember 2019 Antwort ✓
    Optionen
    teste mal, ob du mit diesem Shortcut im BIOS wieder zwischen Optane und AHCI wählen kannst, und ob unter AHCI das Problem nicht mehr auftritt. Was derjenige, der mir die Information zukommen ließ, von diesem Feature hält, habe ich weggelassen. Ich finde, daß man einen Preis für eines der "bescheuertsten Features des Jahres" verleihen könnte:


    Übersetzt: Der (einstellbare) SATA Mode wird erst sichtbar, wenn der User "Strg + S " unter dem Reiter "Main" drückt.
    Gruß
    Jochen
    Edit: Daß die Option nicht mehr offen zur Verfügung steht, betrifft die Windows User ähnlich stark, wie die Linux Nutzer. Hat nichts mit "Linux ignorieren" zu tun. Es gibt einige Windows User, die hier in der Community berichten, daß neu installierte NVMe SSDs im Optane Modus nicht erkannt  werden, und über andere, ähnliche Probleme.
    Man sollte aktuell auch als Windows User bei einem Clean Install von Windows vorher den AHCI Modus aktivieren, um potentiellen Problemen aus dem Weg zu gehen.
    "There's more to the picture than meets the eye ..."
     _______________________________________________
    Bitte bei der hilfreichsten Antwort die Markierung als Lösung nicht vergessen; du hilfst damit anderen, die das selbe Problem haben!
    "Likes"? Warum nicht! ;-)
    _____________________________________________
    Ich bin kein Acer Mitarbeiter!  :-)

  • Oldtjikko
    Oldtjikko Member Beiträge: 2 New User
    Optionen
    Wow ich wünche dir ein extrem erfolgreiches neues Jahr.

    Linux bootet wieder!

    Gruß
  • pfm
    pfm Member Beiträge: 2 New User
    Optionen
    Hat bei mir perfekt funktioniert, danke für den Tipp. Aber:

    Bei meinem Acer Swift 3 SF314-57mit Ubuntu 20.04 LTS hängt sich manchmal nach längerem Gebrauch Bluetooth auf. Danach lässt sich das Notebook nicht mehr herunterfahren. Ich kann zwar nach einigem Hin und Her die Maus wieder via Bluetooth verbinden, aber um komplett auszuschalten muss ich laaaange die Power Taste drücken. Und danach setzt sich das BIOS wieder auf Originalzustand zurück, dh. Die SSD wird auf Optane Raid zurückgesetzt was ich dann wieder manuell auf ACHI ändern muss.
    Wer hat eine Idee, ob die HW oder Ubuntu das Problem ist???? Und vor allem ob und was ich tun kann.